summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorVasudev Kamath <vasudev@copyninja.info>2016-12-24 11:08:16 +0530
committerVasudev Kamath <vasudev@copyninja.info>2016-12-24 11:18:03 +0530
commit07d03bdcd6f3aa787b9589b4b93f05402b576a35 (patch)
tree6db1a00e312222197d9908168a543e098438a1ca /debian
parent442ce6d32bf25c2fb66fa27e8f7c71c18ace9d6a (diff)
Enable RST module as part of baresip-x11
Diffstat (limited to 'debian')
-rw-r--r--debian/baresip-x11.install4
-rwxr-xr-xdebian/rules12
2 files changed, 11 insertions, 5 deletions
diff --git a/debian/baresip-x11.install b/debian/baresip-x11.install
index ec6cfca..905ddb1 100644
--- a/debian/baresip-x11.install
+++ b/debian/baresip-x11.install
@@ -1,4 +1,6 @@
usr/lib/baresip/modules/cairo.so
usr/lib/baresip/modules/vidinfo.so
usr/lib/baresip/modules/x11.so
-usr/lib/baresip/modules/x11grab.so \ No newline at end of file
+usr/lib/baresip/modules/x11grab.so
+usr/lib/baresip/modules/rst.so
+usr/lib/baresip/modules/vidinfo.so \ No newline at end of file
diff --git a/debian/rules b/debian/rules
index bed0eca..4aed358 100755
--- a/debian/rules
+++ b/debian/rules
@@ -11,17 +11,20 @@ DEB_COPYRIGHT_CHECK_IGNORE_PATHS = debian/
# Build-Depends
dev-deps = cairo2 rem asound2 avcodec avformat avdevice
dev-deps += gstreamer1.0 re evdev gsm1 spandsp vpx opus
-dev-deps += gtk2.0 gstreamer-plugins-base1.0 x11 xext
+dev-deps += gtk2.0 gstreamer-plugins-base1.0 x11 xext mpg123
deps = $(patsubst %, $(comma) lib%-dev,$(dev-deps))
deps +=, pkg-config
-
CDBS_BUILD_DEPENDS +=, $(deps)
DEB_INSTALL_DOCS_ALL += README.md docs/TODO
DEB_INSTALL_EXAMPLES_$(pkg) = docs/examples/*
-# Do not install gtk as part of baresip
-DEB_DH_INSTALL_ARGS_baresip = -Xgtk.so -Xavcodec.so -Xavformat.so -Xgst1.so -Xgst_video1.so -Xcairo.so -Xvidinfo.so -Xx11.so -Xx11grab.so
+# Do not install these modules as part of baresip
+DEB_DH_INSTALL_ARGS_baresip = -Xgtk.so \
+ -Xavformat.so -Xavcodec.so \
+ -Xgst1.so -Xgst_video1.so \
+ -Xcairo.so -Xx11.so -Xx11grab.so \
+ -Xvidinfo.so -Xrst.so
# LIBDIR for installation
LIBDIR=/usr/lib
@@ -42,6 +45,7 @@ build_rem_package:
USE_AVFORMAT=1 \
USE_CAIRO=1 \
USE_X11=1 \
+ USE_MPG123=1 \
USE_CONS=1 \
USE_EVDEV=1 \
USE_G711=1 \