summaryrefslogtreecommitdiff
path: root/mk/modules.mk
diff options
context:
space:
mode:
authorJonathan Sieber <jonathan_sieber@yahoo.de>2017-04-06 18:36:58 +0200
committerAlfred E. Heggestad <alfred.heggestad@gmail.com>2017-04-06 18:36:58 +0200
commitae1f6ea602a5b206f61e678b5249c01abe7cb7df (patch)
tree37e5ccc2647ae745fa3d8adcc12fec93efcdc60a /mk/modules.mk
parent6a9ccd80ef607eb3600c98ef5692e552d1b7302f (diff)
Video Display Support for Raspberry Pi (#228)
* Adding a new video display module for the Raspberry Pi... * Made it work with libomxil-bellagio - Fixed framing woes with vidconv() :) * Some Attention to the build system, Automatically use libomx-bellagio or RPi OMX API Introduces USE_OMX_RPI and USE_OMX_BELLAGIO in mk/modules.mk use sys_usleep() Removed pthread mutexes, they are not needed anymore
Diffstat (limited to 'mk/modules.mk')
-rw-r--r--mk/modules.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/mk/modules.mk b/mk/modules.mk
index 1aa2166..439c214 100644
--- a/mk/modules.mk
+++ b/mk/modules.mk
@@ -32,6 +32,9 @@
# USE_L16 L16 audio codec
# USE_MPA MPA audo codec
# USE_MPG123 Use mpg123
+# USE_OMX_RPI RaspberryPi VideoCore display driver
+# USE_OMX_BELLAGIO libomxil-bellagio xvideosink driver
+# USE_OPUS Opus audio codec
# USE_OPUS Opus audio codec
# USE_OSS OSS audio driver
# USE_PLC Packet Loss Concealment
@@ -201,6 +204,14 @@ USE_VPX := $(shell [ -f $(SYSROOT)/include/vpx/vp8.h ] \
|| [ -f $(SYSROOT)/local/include/vpx/vp8.h ] \
|| [ -f $(SYSROOT_ALT)/include/vpx/vp8.h ] \
&& echo "yes")
+USE_OMX_RPI := $(shell [ -f /opt/vc/include/bcm_host.h ] || \
+ [ -f $(SYSROOT)/include/bcm_host.h ] \
+ || [ -f $(SYSROOT_ALT)/include/bcm_host.h ] \
+ && echo "yes")
+USE_OMX_BELLAGIO := $(shell [ -f /usr/include/OMX_Core.h ] \
+ || [ -f $(SYSROOT)/include/OMX_Core.h ] \
+ || [ -f $(SYSROOT_ALT)/include/OMX_Core.h ] \
+ && echo "yes")
else
# Windows.
# Accounts for mingw with Windows SDK (formerly known as Platform SDK)
@@ -413,6 +424,12 @@ endif
ifneq ($(USE_V4L2),)
MODULES += v4l2 v4l2_codec
endif
+ifneq ($(USE_OMX_RPI),)
+MODULES += omx
+endif
+ifneq ($(USE_OMX_BELLAGIO),)
+MODULES += omx
+endif
ifneq ($(USE_VPX),)
MODULES += vp8
MODULES += $(shell pkg-config 'vpx >= 1.3.0' && echo "vp9")