summaryrefslogtreecommitdiff
path: root/modules/omx
diff options
context:
space:
mode:
authorAlfred E. Heggestad <alfred.heggestad@gmail.com>2018-01-07 10:38:35 +0000
committerAlfred E. Heggestad <alfred.heggestad@gmail.com>2018-01-07 10:38:35 +0000
commit42b0d07efad8fe684159daa40b56b841e79f0343 (patch)
treec1853afbfade2bfe305584b9e149d8ec516a88b2 /modules/omx
parent9e7cc48e964ee6a094fe762c31e66bdfc1388ae7 (diff)
omx: use -isystem to avoid warning in system header files
Diffstat (limited to 'modules/omx')
-rw-r--r--modules/omx/module.mk9
1 files changed, 5 insertions, 4 deletions
diff --git a/modules/omx/module.mk b/modules/omx/module.mk
index 958a1a5..c7a796d 100644
--- a/modules/omx/module.mk
+++ b/modules/omx/module.mk
@@ -9,10 +9,11 @@ $(MOD)_SRCS += omx.c module.c
ifneq ($(USE_OMX_RPI),)
$(MOD)_CFLAGS := -DRASPBERRY_PI -DOMX_SKIP64BIT \
- -I/usr/local/include/interface/vmcs_host/linux/ \
- -I /usr/local/include/interface/vcos/pthreads/ \
- -I /opt/vc/include -I /opt/vc/include/interface/vmcs_host/linux \
- -I /opt/vc/include/interface/vcos/pthreads
+ -isystem /usr/local/include/interface/vmcs_host/linux/ \
+ -isystem /usr/local/include/interface/vcos/pthreads/ \
+ -isystem /opt/vc/include \
+ -isystem /opt/vc/include/interface/vmcs_host/linux \
+ -isystem /opt/vc/include/interface/vcos/pthreads
$(MOD)_LFLAGS += -lvcos -lbcm_host -lopenmaxil -L /opt/vc/lib
endif