summaryrefslogtreecommitdiff
path: root/test/srcs.mk
diff options
context:
space:
mode:
authorAlfred E. Heggestad <aeh@db.org>2015-10-04 21:24:31 +0200
committerAlfred E. Heggestad <aeh@db.org>2015-10-04 21:24:31 +0200
commit5cbd1d17177236f7c4515f077c18d328c76af9b1 (patch)
tree287a08249ce9a545318c67985688902e221b4f6d /test/srcs.mk
parent26b1c86e32abc1d2543d667c80b3532e6e178c16 (diff)
test: use new sipsrv from retest
Diffstat (limited to 'test/srcs.mk')
-rw-r--r--test/srcs.mk18
1 files changed, 15 insertions, 3 deletions
diff --git a/test/srcs.mk b/test/srcs.mk
index 4115fdb..1caafbb 100644
--- a/test/srcs.mk
+++ b/test/srcs.mk
@@ -4,12 +4,24 @@
# Copyright (C) 2010 Creytiv.com
#
+
+#
+# Test-cases:
+#
TEST_SRCS += cmd.c
TEST_SRCS += ua.c
+TEST_SRCS += cplusplus.c
-TEST_SRCS += sip_server.c
-TEST_SRCS += test.c
-TEST_SRCS += cplusplus.c
+#
+# Mocks
+#
+TEST_SRCS += mock/sipsrv.c
+ifneq ($(USE_TLS),)
+TEST_SRCS += mock/cert.c
+endif
+
+
+TEST_SRCS += test.c
TEST_SRCS += main.c