summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile2
-rw-r--r--debian/changelog6
-rw-r--r--docs/ChangeLog84
-rw-r--r--include/baresip.h2
-rw-r--r--mk/Doxyfile2
-rw-r--r--rpm/baresip.spec2
6 files changed, 94 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 247fb99..a60c1eb 100644
--- a/Makefile
+++ b/Makefile
@@ -13,7 +13,7 @@
USE_VIDEO := 1
PROJECT := baresip
-VERSION := 0.5.4
+VERSION := 0.5.5
DESCR := "Baresip is a modular SIP User-Agent with audio and video support"
# Verbose and silent build modes
diff --git a/debian/changelog b/debian/changelog
index 392aaed..678c25b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+baresip (0.5.5) unstable; urgency=medium
+
+ * version 0.5.5
+
+ -- Alfred E. Heggestad <alfred.heggestad@gmail.com> Thu, 7 Sept 2017 16:00:00 +0200
+
baresip (0.5.4) unstable; urgency=medium
* version 0.5.4
diff --git a/docs/ChangeLog b/docs/ChangeLog
index 1668166..f234482 100644
--- a/docs/ChangeLog
+++ b/docs/ChangeLog
@@ -1,3 +1,87 @@
+2017-09-07 Alfred E. Heggestad <alfred.heggestad@gmail.com>
+
+ * Version 0.5.5
+
+ * GIT URL: https://github.com/alfredh/baresip.git
+ * GIT tag: v0.5.5
+ * NOTE: Requires libre v0.5.5 or later
+ Requires librem v0.5.0 or later
+
+ * new commands:
+ - insmod module.so -- Load a module
+ - rmmod module.so -- Unload a module
+
+ * config:
+ - fullscreen yes|no Enable fullscreen display
+
+ * baresip-core:
+ - account: optional param 'auth_pass' for password
+ add account_set_auth_pass()
+ add account_aor()
+ add account_auth_pass()
+ - contact: add update handler (thanks Jonathan Sieber)
+ - h264: add rtp_ts RTP Timestamp
+ - module: add module_load/unload
+ remove list of application modules
+ - stream: reset timer on incoming RTCP packets (fixes #271)
+ - ui: make the API re-entrant
+ - video: add RTP timestamp to videnc packet handler
+ add video_calc_rtp_timestamp()
+ add video_calc_seconds()
+ - video: use RTP timestamp from video encoder
+
+ * selftest:
+ - add test for video timestamps
+
+ * Modules:
+
+ * account: move password prompt here
+
+ * av1: use encoder PTS to calculate RTP timestamp
+
+ * avcodec: use encoder PTS to calculate RTP timestamp
+ use level_idc=0x1f for x264
+
+ * cons: updated UI api
+
+ * evdev: updated UI api
+
+ * gst_video: use encoder PTS to calculate RTP timestamp
+
+ * gst_video1: use encoder PTS to calculate RTP timestamp
+
+ * h265: use encoder PTS to calculate RTP timestamp
+ fix FU decoder bug
+
+ * httpd: updated UI api
+
+ * ice: move gathering from lib to app
+ (requires libre v0.5.5 or later)
+
+ * menu: updated UI api
+
+ * mwi: updated UI api
+
+ * presence: Handle contacts added at run-time
+ (thanks Jonathan Sieber)
+
+ * sdl: updated UI api
+
+ * sdl2: add support for fullscreen video
+
+ * stdio: updated UI api
+
+ * v4l: add support for more pixel-formats
+
+ * v4l2_codec: use encoder PTS to calculate RTP timestamp
+
+ * vp8: use encoder PTS to calculate RTP timestamp
+
+ * vp9: use encoder PTS to calculate RTP timestamp
+
+ * wincons: updated UI api
+
+
2017-06-24 Alfred E. Heggestad <alfred.heggestad@gmail.com>
* Version 0.5.4
diff --git a/include/baresip.h b/include/baresip.h
index d75d8fb..efbbb0f 100644
--- a/include/baresip.h
+++ b/include/baresip.h
@@ -13,7 +13,7 @@ extern "C" {
/** Defines the Baresip version string */
-#define BARESIP_VERSION "0.5.4"
+#define BARESIP_VERSION "0.5.5"
#ifndef NET_MAX_NS
diff --git a/mk/Doxyfile b/mk/Doxyfile
index fdef302..05b7bbc 100644
--- a/mk/Doxyfile
+++ b/mk/Doxyfile
@@ -4,7 +4,7 @@
# Project related configuration options
#---------------------------------------------------------------------------
PROJECT_NAME = baresip
-PROJECT_NUMBER = 0.5.4
+PROJECT_NUMBER = 0.5.5
OUTPUT_DIRECTORY = ../baresip-dox
CREATE_SUBDIRS = NO
OUTPUT_LANGUAGE = English
diff --git a/rpm/baresip.spec b/rpm/baresip.spec
index 1f96144..e29dfbc 100644
--- a/rpm/baresip.spec
+++ b/rpm/baresip.spec
@@ -1,5 +1,5 @@
%define name baresip
-%define ver 0.5.4
+%define ver 0.5.5
%define rel 1
Summary: Modular SIP useragent