summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile2
-rw-r--r--debian/changelog6
-rw-r--r--docs/ChangeLog53
-rw-r--r--include/baresip.h2
-rw-r--r--mk/Doxyfile2
-rw-r--r--rpm/baresip.spec2
6 files changed, 63 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index d5b60bf..9d2b847 100644
--- a/Makefile
+++ b/Makefile
@@ -13,7 +13,7 @@
USE_VIDEO := 1
PROJECT := baresip
-VERSION := 0.4.18
+VERSION := 0.4.19
DESCR := "Baresip is a modular SIP User-Agent with audio and video support"
# Verbose and silent build modes
diff --git a/debian/changelog b/debian/changelog
index 102bfa4..4a87c69 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+baresip (0.4.19) unstable; urgency=medium
+
+ * version 0.4.19
+
+ -- Alfred E. Heggestad <aeh@db.org> Fri, 20 May 2016 20:00:00 +0100
+
baresip (0.4.18) unstable; urgency=medium
* version 0.4.18
diff --git a/docs/ChangeLog b/docs/ChangeLog
index 65c100e..a1fcaf2 100644
--- a/docs/ChangeLog
+++ b/docs/ChangeLog
@@ -1,3 +1,56 @@
+2016-05-20 Alfred E. Heggestad <aeh@db.org>
+
+ * Version 0.4.19
+
+ * GIT URL: https://github.com/alfredh/baresip.git
+ * GIT tag: v0.4.19
+ * NOTE: Requires libre v0.4.14 or later
+ Requires librem v0.4.7 or later
+
+ * new modules:
+ - mpa MPA Speech and Audio Codec (thanks Christian Hoene)
+
+ * baresip-core:
+ - audio: remove is_g722 exception
+ use aucodec's rtp clockrate for calculating RTP timestamp
+ plc: make sure sampc is exactly one ptime frame
+ - aucodec: split srate into DSP srate and RTP clockrate
+ (these are different for e.g. G.722 and MDA)
+ - mos: add mos_calculate() (thanks Lorenzo Mangani)
+ - net: use configured dns servers only, if specified
+ - ua: fix potential NULL-pointer crash for uag.cfg
+
+ * selftest:
+ - add test for SIP registration with DNS
+ - add test for SIP registration with authentication
+ - add test for MOS calculations
+ - added a mock DNS Server
+ - added a mock SIP Server
+
+ * Modules:
+
+ * aucodec: add support for NV12 and YUVJ420P pixel formats
+
+ * daala: update to libdaala version 0.0-1564-g79787c7
+
+ * gtk: fix autodetection of libgtk+ 2.0 (thanks Charles Lehner)
+
+ * h265: remove call to x265_cleanup, caused crash on OpenBSD
+
+ * mpa: new module that implements MPA Speech and Audio Codec
+ (this module was contributed by Christian Hoene)
+
+ * opus: added new configuration parameters:
+ opus_cbr {yes,no} # Constant Bitrate (inverse of VBR)
+ opus_inbandfec {yes,no} # Enable inband FEC
+ opus_dtx {yes,no} # Enable DTX
+
+ * presence: improved interoperability, allow white space before
+ xml element closing tags (thanks Juha Heinanen)
+
+ * x11: added borderless window (thanks Doug Blewett)
+
+
2016-03-12 Alfred E. Heggestad <aeh@db.org>
* Version 0.4.18
diff --git a/include/baresip.h b/include/baresip.h
index cb99946..201ecb5 100644
--- a/include/baresip.h
+++ b/include/baresip.h
@@ -13,7 +13,7 @@ extern "C" {
/** Defines the Baresip version string */
-#define BARESIP_VERSION "0.4.18"
+#define BARESIP_VERSION "0.4.19"
/* forward declarations */
diff --git a/mk/Doxyfile b/mk/Doxyfile
index 6ca882a..bc393ba 100644
--- a/mk/Doxyfile
+++ b/mk/Doxyfile
@@ -4,7 +4,7 @@
# Project related configuration options
#---------------------------------------------------------------------------
PROJECT_NAME = baresip
-PROJECT_NUMBER = 0.4.18
+PROJECT_NUMBER = 0.4.19
OUTPUT_DIRECTORY = ../baresip-dox
CREATE_SUBDIRS = NO
OUTPUT_LANGUAGE = English
diff --git a/rpm/baresip.spec b/rpm/baresip.spec
index 3627032..7504ffa 100644
--- a/rpm/baresip.spec
+++ b/rpm/baresip.spec
@@ -1,5 +1,5 @@
%define name baresip
-%define ver 0.4.18
+%define ver 0.4.19
%define rel 1
Summary: Modular SIP useragent