summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/patches/1001_gcc7_compat.patch10
-rw-r--r--debian/patches/2001_drop_libre_so_check.patch6
2 files changed, 8 insertions, 8 deletions
diff --git a/debian/patches/1001_gcc7_compat.patch b/debian/patches/1001_gcc7_compat.patch
index 14f11e7..cce9643 100644
--- a/debian/patches/1001_gcc7_compat.patch
+++ b/debian/patches/1001_gcc7_compat.patch
@@ -5,11 +5,11 @@ Description: Use -D_GNU_SOURCE for gcc-7 compatibility
_GNU_SOURCE.
Author: Steve Langasek <steve.langasek@ubuntu.com>
Bug-Debian: https://bugs.debian.org/872406
-
-Index: baresip-0.5.4/Makefile
-===================================================================
---- baresip-0.5.4.orig/Makefile
-+++ baresip-0.5.4/Makefile
+Last-Update: 2017-08-26
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- a/Makefile
++++ b/Makefile
@@ -49,6 +49,7 @@
CFLAGS += -I. -Iinclude -I$(LIBRE_INC) -I$(SYSROOT)/include
CFLAGS += -I$(LIBREM_PATH)/include
diff --git a/debian/patches/2001_drop_libre_so_check.patch b/debian/patches/2001_drop_libre_so_check.patch
index 6d05a4b..8d06f7e 100644
--- a/debian/patches/2001_drop_libre_so_check.patch
+++ b/debian/patches/2001_drop_libre_so_check.patch
@@ -10,7 +10,7 @@ Last-Update: 2016-02-08
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
--- a/Makefile
+++ b/Makefile
-@@ -163,17 +163,13 @@
+@@ -162,17 +162,13 @@
@echo "ERROR: Missing header files for libre. Check LIBRE_INC"
@exit 2
endif
@@ -29,7 +29,7 @@ This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
$(STATICLIB): $(LIB_OBJS)
@echo " AR $@"
-@@ -203,7 +199,7 @@
+@@ -202,7 +198,7 @@
$(HIDE)$(LD) $(LFLAGS) $(APP_LFLAGS) $^ ../re/libre.a $(LIBS) -o $@
else
$(HIDE)$(LD) $(LFLAGS) $(APP_LFLAGS) $^ \
@@ -38,7 +38,7 @@ This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
endif
-@@ -214,7 +210,7 @@
+@@ -213,7 +209,7 @@
$(TEST_BIN): $(STATICLIB) $(TEST_OBJS)
@echo " LD $@"
$(HIDE)$(CXX) $(LFLAGS) $(TEST_OBJS) \