summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile2
-rw-r--r--debian/changelog6
-rw-r--r--debian/control4
-rw-r--r--docs/ChangeLog77
-rw-r--r--docs/README2
-rw-r--r--include/baresip.h2
-rw-r--r--mk/Doxyfile2
-rw-r--r--rpm/baresip.spec2
8 files changed, 90 insertions, 7 deletions
diff --git a/Makefile b/Makefile
index c31eec7..33fb56c 100644
--- a/Makefile
+++ b/Makefile
@@ -13,7 +13,7 @@
USE_VIDEO := 1
PROJECT := baresip
-VERSION := 0.4.11
+VERSION := 0.4.12
ifndef LIBRE_MK
LIBRE_MK := $(shell [ -f ../re/mk/re.mk ] && \
diff --git a/debian/changelog b/debian/changelog
index 5d3d57e..8d6dbf1 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+baresip (0.4.12) unstable; urgency=low
+
+ * version 0.4.12
+
+ -- Alfred E. Heggestad <aeh@db.org> Wed, 24 Dec 2014 14:00:00 +0100
+
baresip (0.4.11) unstable; urgency=low
* version 0.4.11
diff --git a/debian/control b/debian/control
index 3ee592a..dc6f989 100644
--- a/debian/control
+++ b/debian/control
@@ -3,12 +3,12 @@ Section: comm
Priority: optional
Maintainer: Alfred E. Heggestad <aeh@db.org>
Standards-Version: 3.9.5
-Build-Depends: debhelper (>= 9.20120311), librem-dev (>= 0.4.5), libre-dev (>= 0.4.10), libasound2-dev, libavformat-dev, libavdevice-dev
+Build-Depends: debhelper (>= 9.20120311), librem-dev (>= 0.4.5), libre-dev (>= 0.4.11), libasound2-dev, libavformat-dev, libavdevice-dev
Homepage: http://www.creytiv.com/
Package: baresip
Architecture: any
-Depends: ${shlibs:Depends}, ${misc:Depends}, librem (>= 0.4.5), libre (>= 0.4.10)
+Depends: ${shlibs:Depends}, ${misc:Depends}, librem (>= 0.4.5), libre (>= 0.4.11)
Description: Modular SIP User-Agent with audio and video support
Design goals:
.
diff --git a/docs/ChangeLog b/docs/ChangeLog
index 3282ab5..5ce39d9 100644
--- a/docs/ChangeLog
+++ b/docs/ChangeLog
@@ -1,3 +1,80 @@
+2014-12-24 Alfred E. Heggestad <aeh@db.org>
+
+ * Version 0.4.12
+
+ * GIT commit 67993e35d980375458348b264c4a35a944bb5180
+ * NOTE: Requires libre v0.4.11 or later
+
+ * baresip:
+ - account: add regint and pubint
+ - audio: fix checking of sample-rate range
+ - config: remove the "input" block
+ - config: added support for quoted device parameters
+ - config: fix conversion of bandwidth to kbit/s
+ - config: generate more relevant config for FreeBSD and OpenBSD
+ (thanks Dmitrij D. Czarkoff)
+ - reg: add support for extracting GRUU parameter
+ - main: add -p option to set path to audio files
+ - sipreq: make response-handler optional
+ - ua: add support for GRUU (RFC 5627)
+ (many thanks to Juha Heinanen for starting this work and
+ helping out with the testing)
+ - ua: moved presence-status to each struct ua instance
+ - ua: add presence status to each User-Agent instance
+ - ua: use public-GRUU if set, otherwise local cuser
+ - ui: make UI single instance
+ - video: add VIDENC_INTERNAL_FMT (suggested by Victor Sergienko)
+
+ * docs: added sample configuration files
+
+ * account: added pubint for Publishing Interval
+
+ * avcodec: upgrade to recent ffmpeg/libav APIs
+ either FFmpeg or libav can be used
+
+ * celt: deleted module (replaced by opus)
+
+ * cons: update usage of struct ui, added output handler
+ added config: cons_listen 0.0.0.0:5555
+
+ * evdev: update usage of struct ui, added output handler
+ added config: evdev_device /dev/input/event0
+
+ * httpd: added ui output handler
+
+ * menu: added command 'o' for sending OPTION request
+ (thanks to Juha Heinanen)
+
+ added command 'D' for accepting incoming calls
+
+ * mwi: subscribe to MWI after Registration succeeded
+ (thanks to Juha Heinanen)
+
+ * opensles: add double-buffering and some tuning
+ (thanks to Francesco Bradascio)
+
+ * opus: added config "opus_bitrate" (thanks to Sebastian Reimers)
+
+ * presence: added support for PUBLISH (thanks to Juha Heinanen)
+ interop fixes and tuning
+
+ * stdio: update usage of struct ui, added output handler
+
+ * uuid: use internal version of generating UUID
+
+ * v4l2: use memory mapped mode only
+
+ * vumeter: dont call tmr_start from non-RE thread
+
+ * wincons: update usage of struct ui, added output handler
+
+ * winwave: fix bug when closing player device
+ (thanks to Tomasz Ostrowski)
+ add support for mapping device name to index
+
+ * zrtp: add support for verify SAS (thanks to Ingo Feinerer)
+
+
2014-06-21 Alfred E. Heggestad <aeh@db.org>
* Version 0.4.11
diff --git a/docs/README b/docs/README
index fbb8cf1..ee1e96b 100644
--- a/docs/README
+++ b/docs/README
@@ -304,7 +304,7 @@ Supported compilers:
External dependencies:
-libre v0.4.10 or later
+libre v0.4.11 or later
librem v0.4.6 or later
diff --git a/include/baresip.h b/include/baresip.h
index 741a69c..b2c2c92 100644
--- a/include/baresip.h
+++ b/include/baresip.h
@@ -13,7 +13,7 @@ extern "C" {
/** Defines the Baresip version string */
-#define BARESIP_VERSION "0.4.11"
+#define BARESIP_VERSION "0.4.12"
/* forward declarations */
diff --git a/mk/Doxyfile b/mk/Doxyfile
index 59df76e..e457280 100644
--- a/mk/Doxyfile
+++ b/mk/Doxyfile
@@ -4,7 +4,7 @@
# Project related configuration options
#---------------------------------------------------------------------------
PROJECT_NAME = baresip
-PROJECT_NUMBER = 0.4.11
+PROJECT_NUMBER = 0.4.12
OUTPUT_DIRECTORY = ../baresip-dox
CREATE_SUBDIRS = NO
OUTPUT_LANGUAGE = English
diff --git a/rpm/baresip.spec b/rpm/baresip.spec
index 2e6f429..de287cc 100644
--- a/rpm/baresip.spec
+++ b/rpm/baresip.spec
@@ -1,5 +1,5 @@
%define name baresip
-%define ver 0.4.11
+%define ver 0.4.12
%define rel 1
Summary: Modular SIP useragent