summaryrefslogtreecommitdiff
path: root/mk/modules.mk
diff options
context:
space:
mode:
Diffstat (limited to 'mk/modules.mk')
-rw-r--r--mk/modules.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/mk/modules.mk b/mk/modules.mk
index 0bf72a9..2481f0e 100644
--- a/mk/modules.mk
+++ b/mk/modules.mk
@@ -175,6 +175,11 @@ USE_VPX := $(shell [ -f $(SYSROOT)/include/vpx/vp8.h ] \
USE_GTK := $(shell [ -f $(SYSROOT)/include/gtk-2.0/gtk/gtk.h ] || \
[ -f $(SYSROOT)/local/include/gtk-2.0/gtk/gtk.h ] || \
[ -f $(SYSROOT_ALT)/include/gtk-2.0/gtk/gtk.h ] && echo "yes")
+else
+# Windows.
+# Accounts for mingw with Windows SDK (formerly known as Platform SDK)
+# mounted at /winsdk
+USE_DSHOW := $(shell [ -f /winsdk/Include/um/dshow.h ] && echo "yes")
endif
# Platform specific modules
@@ -364,3 +369,7 @@ endif
ifneq ($(USE_GTK),)
MODULES += gtk
endif
+
+ifneq ($(USE_DSHOW),)
+MODULES += dshow
+endif