summaryrefslogtreecommitdiff
path: root/mk/modules.mk
diff options
context:
space:
mode:
Diffstat (limited to 'mk/modules.mk')
-rw-r--r--mk/modules.mk10
1 files changed, 2 insertions, 8 deletions
diff --git a/mk/modules.mk b/mk/modules.mk
index 9211dfd..a479e6a 100644
--- a/mk/modules.mk
+++ b/mk/modules.mk
@@ -171,11 +171,6 @@ USE_MPA := $(shell [ -f $(SYSROOT)/include/twolame.h ] || \
[ -f $(SYSROOT_ALT)/include/twolame.h ] && echo "yes")
endif
endif
-USE_SPEEX := $(shell [ -f $(SYSROOT)/include/speex.h ] || \
- [ -f $(SYSROOT)/include/speex/speex.h ] || \
- [ -f $(SYSROOT)/local/include/speex.h ] || \
- [ -f $(SYSROOT)/local/include/speex/speex.h ] || \
- [ -f $(SYSROOT_ALT)/include/speex/speex.h ] && echo "yes")
USE_SPEEX_AEC := $(shell [ -f $(SYSROOT)/include/speex/speex_echo.h ] || \
[ -f $(SYSROOT)/local/include/speex/speex_echo.h ] || \
[ -f $(SYSROOT_ALT)/include/speex/speex_echo.h ] && echo "yes")
@@ -275,6 +270,7 @@ MODULES += menu contact vumeter mwi account natpmp httpd
MODULES += srtp
MODULES += uuid
MODULES += debug_cmd
+MODULES += ctrl_tcp
ifneq ($(HAVE_LIBMQTT),)
MODULES += mqtt
@@ -285,10 +281,8 @@ MODULES += aubridge aufile
endif
ifneq ($(USE_VIDEO),)
MODULES += vidloop selfview vidbridge
-ifneq ($(HAVE_PTHREAD),)
MODULES += fakevideo
endif
-endif
ifneq ($(USE_ALSA),)
@@ -308,10 +302,10 @@ MODULES += avcodec
ifneq ($(USE_AVFORMAT),)
MODULES += avformat
endif
+endif
ifneq ($(USE_AVAHI),)
MODULES += avahi
endif
-endif
ifneq ($(USE_BV32),)
MODULES += bv32
endif