summaryrefslogtreecommitdiff
path: root/lisp/Makefile
diff options
context:
space:
mode:
authorMatt Simmons <simmonmt@acm.org>1997-11-02 06:32:38 +0000
committerMatt Simmons <simmonmt@acm.org>1997-11-02 06:32:38 +0000
commit010bfa7e6263ea0ca7c5f461150641712d7dc4cd (patch)
tree78fb8e4696e9ca0675b11ef059dd4936176ddfa9 /lisp/Makefile
parent53f5596e4a2503381ea14f5fa6eb2b3e9aa1ad82 (diff)
Support for bbdb-sc.el
Diffstat (limited to 'lisp/Makefile')
-rw-r--r--lisp/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/lisp/Makefile b/lisp/Makefile
index 41c9207..533fce8 100644
--- a/lisp/Makefile
+++ b/lisp/Makefile
@@ -4,6 +4,9 @@
# $Id$
#
# $Log$
+# Revision 1.3 1997/11/02 06:32:38 simmonmt
+# Support for bbdb-sc.el
+#
# Revision 1.2 1997/10/12 00:24:41 simmonmt
# Changed VM, GNUS, and MHE definitions. If the corresponding DIR
# variables are set, the (the DIR vars) are added to load-path. The
@@ -85,12 +88,13 @@ bbdb-vm.elc: bbdb.elc bbdb-vm.el
$(EMACS) -batch -q -l ./bbdb.elc $(VM) -f batch-byte-compile $(@:.elc=.el)
bbdb-srv.elc: bbdb.elc bbdb-srv.el
- @$(EMACS) -batch -q $(PUSHPATH) -l ./bbdb.elc -eval \
- '(if (and (locate-library "gnuserv") (locate-library "itimer")) (byte-compile-file "bbdb-srv.el") (message "Optional package bbdb-srv skipped"))'
+ @$(EMACS) -batch -q $(PUSHPATH) -l ./bbdb.elc -eval '(if (and (locate-library "gnuserv") (locate-library "itimer")) (byte-compile-file "bbdb-srv.el") (message "Optional package bbdb-srv skipped - gnuserv not found"))'
bbdb-reportmail.elc: bbdb.elc bbdb-reportmail.el
- @$(EMACS) -batch -q $(PUSHPATH) -l ./bbdb.elc -eval \
- '(if (locate-library "reportmail") (byte-compile-file "bbdb-reportmail.el") (message "Optional package bbdb-reportmail skipped"))'
+ @$(EMACS) -batch -q $(PUSHPATH) -l ./bbdb.elc -eval '(if (locate-library "reportmail") (byte-compile-file "bbdb-reportmail.el") (message "Optional package bbdb-reportmail skipped - reportmail not found"))'
+
+bbdb-sc.elc: bbdb.elc bbdb-sc.el
+ @$(EMACS) -batch -q $(PUSHPATH) -l ./bbdb.elc -eval '(if (locate-library "supercite") (byte-compile-file "bbdb-sc.el") (message "Optional package bbdb-sc skipped - supercite not found"))'
# bbdb-hooks uses VM macros if it can find VM. If you don't have VM,
# then the $(VM) makefile variable should be undefined or empty.
@@ -101,7 +105,7 @@ bbdb-hooks.elc: bbdb.elc bbdb-hooks.el
autoloads: auto-autoloads.elc
extras: bbdb-print.elc bbdb-ftp.elc bbdb-whois.elc bbdb-xemacs.elc bbdb-srv.elc \
- bbdb-reportmail.elc bbdb-snarf.elc bbdb-w3.elc
+ bbdb-reportmail.elc bbdb-snarf.elc bbdb-w3.elc bbdb-sc.elc
bbdb: bbdb.elc bbdb-com.elc bbdb-hooks.elc extras
rmail: bbdb bbdb-rmail.elc
vm: bbdb bbdb-vm.elc