summaryrefslogtreecommitdiff
path: root/lisp/Makefile
diff options
context:
space:
mode:
authorMatt Simmons <simmonmt@acm.org>1998-03-10 07:33:12 +0000
committerMatt Simmons <simmonmt@acm.org>1998-03-10 07:33:12 +0000
commit65005d4d208c463f37dbbb552685542b3b20cbc8 (patch)
tree398c93898798f2997fb3497344642ece466596ea /lisp/Makefile
parent5c667a8672bd52d39d9b8d0439754534a2c1afbe (diff)
Finally fixed that damn 19.34 :link problem - needed to put OTHERDIR
stuff first in the load-path before loading bbdb.el.
Diffstat (limited to 'lisp/Makefile')
-rw-r--r--lisp/Makefile64
1 files changed, 46 insertions, 18 deletions
diff --git a/lisp/Makefile b/lisp/Makefile
index 3396174..dd13594 100644
--- a/lisp/Makefile
+++ b/lisp/Makefile
@@ -4,6 +4,10 @@
# $Id$
#
# $Log$
+# Revision 1.7 1998/03/10 07:33:12 simmonmt
+# Finally fixed that damn 19.34 :link problem - needed to put OTHERDIR
+# stuff first in the load-path before loading bbdb.el.
+#
# Revision 1.6 1998/02/23 07:23:23 simmonmt
# Support for OTHERDIR, rearranged flags to Emacs so we can use
# bbdb-split-string (19.34 doesn't have split-string)
@@ -41,13 +45,37 @@ VM = -eval '(progn (if (not (string-match "$(VMDIR)" "")) \
(load "vm")) \
(t (load "vm-vars") (load "vm")))))'
-GNUS = -eval '(progn (if (not (string-match "$(GNUSDIR)" "")) \
- (setq load-path (cons "$(GNUSDIR)" load-path))) \
- (load "nntp") (load "gnus"))'
+GNUS = -eval '(if (not (string-match "$(GNUSDIR)" "")) \
+ (setq load-path (cons "$(GNUSDIR)" load-path)))'
+
MHE = -eval '(progn (if (not (string-match "$(MHEDIR)" "")) \
(setq load-path (cons "$(MHEDIR)" load-path))) \
(load "mh-e"))'
+# This is hideous and sick, but FSF 19.34 doesn't ship with split, and we
+# can't load bbdb.el to get bbdb-split because we have to put OTHERDIR
+# at the front of the load-path before loading bbdb.el. This makes my
+# head hurt.
+PUSHPATH= -eval "`\
+ dir=\". $(OTHERDIR)\"; \
+ echo \(setq load-path \(append \(list ; \
+ for i in $$dir ; do \
+ echo \\"$$i\\"\ ; \
+ done ;\
+ echo \) load-path\)\) ; \
+ `"
+
+#foo:
+# @echo $(PUSHPATH)
+# echo
+# $(EMACS) -batch -q $(PUSHPATH) -eval '(message (prin1-to-string load-path))'
+
+#-eval '(setq load-path \
+# (append (bbdb-split (if (/= 0 (length "$(OTHERDIR)")) \
+# (concat ". " "$(OTHERDIR)") \
+# ".") " ") \
+# load-path))'
+
EMACS = xemacs
MAKEINFO = makeinfo
@@ -62,11 +90,6 @@ DEPBINS= ${DEPSRCS:.el=.elc}
SRCS= bbdb.el $(DEPSRCS)
BINS= bbdb.elc $(DEPBINS)
-PUSHPATH= -eval '(setq load-path (append (bbdb-split (if (/= 0 (length "$(OTHERDIR)")) \
- (concat ". " "$(OTHERDIR)") \
- ".") " ") \
- load-path))'
-
syntax:
@echo "" ;\
echo "*** Make should be run from the `cd ..;pwd` directory" ;\
@@ -88,40 +111,44 @@ bbdb-w3.elc: bbdb.elc bbdb-w3.el
bbdb-xemacs.elc: bbdb.elc bbdb-xemacs.el
.el.elc:
- $(EMACS) -batch -q -l ./bbdb.elc $(PUSHPATH) -f batch-byte-compile $<
+ $(EMACS) -batch -q $(PUSHPATH) -l ./bbdb.elc -f batch-byte-compile $<
bbdb.elc: bbdb.el
$(EMACS) -batch -q -f batch-byte-compile ./bbdb.el
bbdb-gnus.elc: bbdb.elc bbdb-gnus.el
- $(EMACS) -batch -q -l ./bbdb.elc $(GNUS) -f batch-byte-compile $(@:.elc=.el)
+ $(EMACS) -batch -q $(PUSHPATH) -l ./bbdb.elc $(GNUS) \
+ -f batch-byte-compile $(@:.elc=.el)
bbdb-mhe.elc: bbdb.elc bbdb-mhe.el
- $(EMACS) -batch -q -l ./bbdb.elc $(MHE) -f batch-byte-compile $(@:.elc=.el)
+ $(EMACS) -batch -q $(PUSHPATH) -l ./bbdb.elc $(MHE) \
+ -f batch-byte-compile $(@:.elc=.el)
bbdb-rmail.elc: bbdb.elc bbdb-rmail.el
- $(EMACS) -batch -q -l ./bbdb.elc $(RMAIL) -f batch-byte-compile $(@:.elc=.el)
+ $(EMACS) -batch -q $(PUSHPATH) -l ./bbdb.elc $(RMAIL) \
+ -f batch-byte-compile $(@:.elc=.el)
bbdb-vm.elc: bbdb.elc bbdb-vm.el
- $(EMACS) -batch -q -l ./bbdb.elc $(VM) -f batch-byte-compile $(@:.elc=.el)
+ $(EMACS) -batch -q $(PUSHPATH) -l ./bbdb.elc $(VM) \
+ -f batch-byte-compile $(@:.elc=.el)
bbdb-srv.elc: bbdb.elc bbdb-srv.el
- $(EMACS) -batch -q -l ./bbdb.elc $(PUSHPATH) -eval '(if (and (locate-library "gnuserv") (locate-library "itimer")) (byte-compile-file "bbdb-srv.el") (message "Optional package bbdb-srv skipped - gnuserv not found"))'
+ $(EMACS) -batch -q $(PUSHPATH) -l ./bbdb.elc -eval '(if (and (locate-library "gnuserv") (locate-library "itimer")) (byte-compile-file "bbdb-srv.el") (message "Optional package bbdb-srv skipped - gnuserv not found"))'
bbdb-reportmail.elc: bbdb.elc bbdb-reportmail.el
- $(EMACS) -batch -q -l ./bbdb.elc $(PUSHPATH) -eval '(if (locate-library "reportmail") (byte-compile-file "bbdb-reportmail.el") (message "Optional package bbdb-reportmail skipped - reportmail not found"))'
+ $(EMACS) -batch -q $(PUSHPATH) -l ./bbdb.elc -eval '(if (locate-library "reportmail") (byte-compile-file "bbdb-reportmail.el") (message "Optional package bbdb-reportmail skipped - reportmail not found"))'
bbdb-sc.elc: bbdb.elc bbdb-sc.el
- $(EMACS) -batch -q -l ./bbdb.elc $(PUSHPATH) -eval '(if (locate-library "supercite") (byte-compile-file "bbdb-sc.el") (message "Optional package bbdb-sc skipped - supercite not found"))'
+ $(EMACS) -batch -q $(PUSHPATH) -l ./bbdb.elc -eval '(if (locate-library "supercite") (byte-compile-file "bbdb-sc.el") (message "Optional package bbdb-sc skipped - supercite not found"))'
# bbdb-hooks uses VM macros if it can find VM. If you don't have VM,
# then the $(VM) makefile variable should be undefined or empty.
bbdb-hooks.elc: bbdb.elc bbdb-hooks.el
- $(EMACS) -batch -q -l ./bbdb.elc $(PUSHPATH) $(VM) \
+ $(EMACS) -batch -q $(PUSHPATH) -l ./bbdb.elc $(VM) \
-f batch-byte-compile $(@:.elc=.el)
autoloads: auto-autoloads.elc
extras: bbdb-print.elc bbdb-ftp.elc bbdb-whois.elc bbdb-xemacs.elc \
bbdb-srv.elc bbdb-reportmail.elc bbdb-snarf.elc bbdb-w3.elc \
- bbdb-sc.elc bbdb-migrate.el
+ bbdb-sc.elc bbdb-migrate.elc
bbdb: bbdb.elc bbdb-com.elc bbdb-hooks.elc extras
rmail: bbdb bbdb-rmail.elc
vm: bbdb bbdb-vm.elc
@@ -145,6 +172,7 @@ deploy:
rcs "-n$(REVTAG)": RCS/* ; \
co -kv RCS/*
+
clean:
$(RM) bbdb.elc bbdb-*.elc bbdb.info auto-autoloads.elc