summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHelmut Grohne <helmut@subdivi.de>2022-02-23 00:09:47 +0000
committerVagrant Cascadian <vagrant@debian.org>2022-02-22 16:58:57 -0800
commitd4869171cc2577fcc4e9362a6dfcfd6fbce1f296 (patch)
tree9feb2e3b15a848c974bacf14331dc969f147b89a
parentbf4a9671d1780a724ac890f14476669b248c474c (diff)
Fix FTCBFS: Use host tools. Closes: #903521
-rwxr-xr-xdebian/rules7
1 files changed, 5 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index bc7a426..f08e610 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,10 +2,13 @@
#
# Debian rules extensively rewritten by Martin Mitchell <martin@debian.org>
+DPKG_EXPORT_BUILDTOOLS=1
+include /usr/share/dpkg/architecture.mk
+-include /usr/share/dpkg/buildtools.mk
+
CFLAGS = -O2 -g -Wall -DUNIX -DNOPROTO -ffile-prefix-map=$(CURDIR)=.
LDFLAGS = -s
-ARCH = $(shell dpkg --print-installation-architecture)
-STRIP=strip --strip-unneeded --remove-section=.note --remove-section=.comment
+STRIP=$(DEB_HOST_GNU_TYPE)-strip --strip-unneeded --remove-section=.note --remove-section=.comment
build:
# Builds the binary package.