summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Marsden <jmarsden@fastmail.fm>2011-07-10 18:06:23 -0700
committerRoberto C. Sanchez <roberto@connexer.com>2014-10-21 22:48:38 -0400
commitbc6baa3433b5781439754ff2a2a4d475986ec393 (patch)
treeba13612d302ef4b300c9c2aaa0db4979110c0e59
parentda83befb5a5c7b5e67b92bcf13ed56952783332a (diff)
Imported Debian patch 2.8.1-2
-rw-r--r--debian/changelog9
-rw-r--r--debian/control5
-rw-r--r--debian/patches/02-prevent-unused-but-set-variable-ftbfs.patch22
-rw-r--r--debian/patches/series1
4 files changed, 36 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 64ea152..c024ea9 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+bibletime (2.8.1-2) unstable; urgency=low
+
+ * debian/patches/02-prevent-unused-but-set-variable-ftbfs.patch:
+ - Prevent FTBFS using recent gcc 4.6 by using an existing upstream fix.
+ * debian/control:
+ - Add Depends: libqt4-svg so toolbar icons display. (Closes: #612661).
+
+ -- Jonathan Marsden <jmarsden@fastmail.fm> Sun, 10 Jul 2011 18:06:23 -0700
+
bibletime (2.8.1-1) unstable; urgency=low
[ Jonathan Marsden ]
diff --git a/debian/control b/debian/control
index cf4294d..bf1dc81 100644
--- a/debian/control
+++ b/debian/control
@@ -13,7 +13,10 @@ Homepage: http://www.bibletime.info/
Package: bibletime
Architecture: any
-Depends: ${shlibs:Depends}, ${misc:Depends}, libqtgui4 (>= 4.4.0), bibletime-data
+Depends: ${shlibs:Depends}, ${misc:Depends},
+ libqtgui4 (>= 4.4.0),
+ libqt4-svg (>=4.4.0),
+ bibletime-data
Provides: sword-frontend
Description: bible study tool for Qt
BibleTime is a free and easy to use bible study tool.
diff --git a/debian/patches/02-prevent-unused-but-set-variable-ftbfs.patch b/debian/patches/02-prevent-unused-but-set-variable-ftbfs.patch
new file mode 100644
index 0000000..d7354d0
--- /dev/null
+++ b/debian/patches/02-prevent-unused-but-set-variable-ftbfs.patch
@@ -0,0 +1,22 @@
+Description: Prevents gcc 4.6 FTBFS (do not create a variable that is never used).
+ The relevant Bibletime upstream git log entry is:
+ commit 984d9f41bdb7efb9477a706fb1f524b2fbc9c54b
+ Author: Gary Holmlund <gary.holmlund@gmail.com>
+ Date: Mon May 16 22:05:02 2011 -0700
+ Fix compile error on Fedora 15
+Origin: upstream, https://gitorious.org/bibletime/bibletime/commit/984d9f41bdb7efb9477a706fb1f524b2fbc9c54b
+Author: Gary Holmlund <gary.holmlund@gmail.com>
+
+Index: debian/src/frontend/keychooser/ckeychooserwidget.cpp
+===================================================================
+--- debian.orig/src/frontend/keychooser/ckeychooserwidget.cpp 2011-07-10 14:10:48.000000000 -0700
++++ debian/src/frontend/keychooser/ckeychooserwidget.cpp 2011-07-10 14:11:20.000000000 -0700
+@@ -180,7 +180,7 @@
+ emit changed(m_comboBox->currentIndex());
+ }
+
+- const QSize dummySize = m_comboBox->sizeHint(); //without this function call the combo box won't be properly sized!
++ m_comboBox->sizeHint(); //without this function call the combo box won't be properly sized!
+ //DON'T REMOVE OR MOVE THE show()! Otherwise QComboBox's sizeHint() function won't work properly!
+ m_comboBox->show();
+
diff --git a/debian/patches/series b/debian/patches/series
index 011c416..0957dca 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1 +1,2 @@
01-fix-search-works-print-crash.patch
+02-prevent-unused-but-set-variable-ftbfs.patch