summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules9
1 files changed, 2 insertions, 7 deletions
diff --git a/debian/rules b/debian/rules
index 3f83528..c615873 100755
--- a/debian/rules
+++ b/debian/rules
@@ -24,7 +24,6 @@ configure-stamp:
#automake
#perl am_edit
$(COMPILER_FLAGS) ./configure $(configkde) --disable-maintainer-mode
- cd bibletime-doc && ./configure $(configkde) --disable-maintainer-mode
touch configure-stamp
build: configure build-stamp
@@ -33,7 +32,6 @@ build-stamp:
# Add here commands to compile the package.
$(COMPILER_FLAGS) $(MAKE)
- cd bibletime-doc && $(MAKE)
touch build-stamp
@@ -47,14 +45,12 @@ clean:
# Add here commands to clean up after the build process.
#-$(MAKE) distclean
-$(MAKE) clean
- -cd bibletime-doc && $(MAKE) clean
#-rm -f `find . -name Makefile.in`
-rm -f `find . -name Makefile`
-rm -f `find . -name *.moc.cpp`
-rm -f `find . -name *_meta_unload.cpp`
-rm subdirs configure.files config.cache config.log config.status
- -cd bibletime-doc && rm subdirs configure.files config.cache config.log config.status
dh_clean
@@ -67,7 +63,6 @@ install: build
# Add here commands to install the package into debian/tmp.
#$(MAKE) install DESTDIR=`pwd`/debian/tmp kde_htmldir=`pwd`/debian/tmp/usr/share/doc/kde/HTML
$(MAKE) install DESTDIR=`pwd`/debian/tmp
- cd bibletime-doc && $(MAKE) install DESTDIR=`pwd`/../debian/tmp
# Install the pixmap for the debian menu item.
install -p -d -o root -g root -m 755 \
@@ -83,7 +78,7 @@ install: build
#temporary fix to stop things from being executable that shouldn't be?
chmod 644 debian/tmp/usr/share/apps/bibletime/pics/*
- chmod 644 debian/tmp/usr/share/apps/bibletime/printing/*
+ #chmod 644 debian/tmp/usr/share/apps/bibletime/printing/*
chmod 644 debian/tmp/usr/share/apps/bibletime/bibletimeui.rc
# Build architecture-independent files here.
@@ -109,7 +104,7 @@ binary-arch: build install
dh_installchangelogs ChangeLog
dh_link
dh_strip
- dh_compress -Xtipdatabase
+ dh_compress -Xtipdatabase -Xdocbook
dh_fixperms
# dh_makeshlibs
dh_installdeb