summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDebian QA Group <packages@qa.debian.org>2016-12-07 14:42:26 -0800
committerAndrea Veri <and@debian.org>2016-12-07 14:42:26 -0800
commit651a83c96c4217e8cec56a562470fdb8997ed60f (patch)
tree60c2cd1ad10d12513b779e2ba743b31248d40295
parent9ba0fb28bc9fcc2e2e578ec59ccc49bcb3b67bcd (diff)
ld_as-needed_FTFBS_fix
=================================================================== Gbp-Pq: Name ld_as-needed_FTFBS_fix.patch
-rw-r--r--src/Makefile.am3
-rw-r--r--src/Makefile.in3
2 files changed, 2 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 8bfe3e1..0a89522 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -4,8 +4,7 @@ bin_PROGRAMS = bitstormlite
localedir = $(datadir)/locale
INCLUDES = $(GTK_CFLAGS) -DLOCALEDIR=\"$(localedir)\"
-bitstormlite_LDFLAGS = -lpthread $(GTK_LIBS) `curl-config --libs`
-bitstormlite_LDADD = $(LIBINTL)
+bitstormlite_LDADD = -lpthread $(GTK_LIBS) `curl-config --libs` $(LIBINTL)
bitstormlite_SOURCES = bdict.cpp\
BitSet.cpp\
diff --git a/src/Makefile.in b/src/Makefile.in
index fd7f222..69c5849 100644
--- a/src/Makefile.in
+++ b/src/Makefile.in
@@ -238,8 +238,7 @@ top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
AUTOMAKE_OPTIONS = foreign
INCLUDES = $(GTK_CFLAGS) -DLOCALEDIR=\"$(localedir)\"
-bitstormlite_LDFLAGS = -lpthread $(GTK_LIBS) `curl-config --libs`
-bitstormlite_LDADD = $(LIBINTL)
+bitstormlite_LDADD = -lpthread $(GTK_LIBS) `curl-config --libs` $(LIBINTL)
bitstormlite_SOURCES = bdict.cpp\
BitSet.cpp\
blist.cpp\