summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael R. Crusoe <michael.crusoe@gmail.com>2022-11-05 20:25:56 +0100
committerÉtienne Mollier <emollier@debian.org>2022-11-05 20:25:56 +0100
commit256800d5f962d4d2bc70e740949c8b66d3aa2ee7 (patch)
tree99dce5e7146cd7a62e51a0a622b6cf13a0d940de
parent3f0d435a2a16c17d0c8e63f1decf0f1314f4597f (diff)
Handle -m64 and -msse2 flags better
Gbp-Pq: Name correct_64bit_test
-rw-r--r--Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/Makefile b/Makefile
index b7753ab..9e751dc 100644
--- a/Makefile
+++ b/Makefile
@@ -61,9 +61,9 @@ ifneq (,$(findstring Darwin,$(shell uname)))
endif
endif
-BITS := 32
-ifneq (,$(findstring $(shell uname -m), x86_64 amd64))
- BITS := 64
+CXXFLAGS += -fopenmp-simd
+CPPFLAGS += -Ithird_party
+ifeq (amd64,$(dpkg-architecture -q DEB_TARGET_ARCH))
ifeq (1, $(SSE_AVX2))
SSE_FLAG := -mavx2 -faligned-new -DSSE_AVX2
else
@@ -71,11 +71,8 @@ ifneq (,$(findstring $(shell uname -m), x86_64 amd64))
endif
POPCNT_CAPABILITY ?= 1
-else ifneq (,$(findstring $(shell uname -m), aarch64 arm64 s390x ppc64 ppc64le))
- BITS := 64
- SSE_FLAG :=
- CXXFLAGS += -fopenmp-simd
- CPPFLAGS += -Ithird_party
+else
+ SSE_FLAG =
POPCNT_CAPABILITY ?= 0
endif