summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Tille <tille@debian.org>2022-11-04 20:15:46 +0100
committerAndreas Tille <tille@debian.org>2022-11-04 20:15:46 +0100
commitf90758ae2ac89e8a02573fac45062a524a5ea5c0 (patch)
tree251576d40df7e7af0e49924c907fac47b0751a9e
parentc9b4d7a6b7b79071925033a5806105660babee59 (diff)
Update patches
-rw-r--r--debian/patches/correct_64bit_test9
-rw-r--r--debian/patches/drop-not-needed-js-from-manual.patch6
-rw-r--r--debian/patches/hardening.patch2
-rw-r--r--debian/patches/no_sanity21
-rw-r--r--debian/patches/reproducible.patch32
-rw-r--r--debian/patches/simde73
-rw-r--r--debian/patches/skip_test_requiring_non-free_libmath-random-perl.patch6
-rw-r--r--debian/patches/use-source-date-epoch-in-Makefile.patch2
8 files changed, 79 insertions, 72 deletions
diff --git a/debian/patches/correct_64bit_test b/debian/patches/correct_64bit_test
index acd08cb..f8349f8 100644
--- a/debian/patches/correct_64bit_test
+++ b/debian/patches/correct_64bit_test
@@ -2,7 +2,7 @@ Author: Michael R. Crusoe <michael.crusoe@gmail.com>
Description: Handle -m64 and -msse2 flags better
--- a/Makefile
+++ b/Makefile
-@@ -61,16 +61,13 @@ ifneq (,$(findstring Darwin,$(shell unam
+@@ -61,9 +61,9 @@ ifneq (,$(findstring Darwin,$(shell unam
endif
endif
@@ -12,7 +12,12 @@ Description: Handle -m64 and -msse2 flags better
+CXXFLAGS += -fopenmp-simd
+CPPFLAGS += -Ithird_party
+ifeq (amd64,$(dpkg-architecture -q DEB_TARGET_ARCH))
- SSE_FLAG := -msse2
+ ifeq (1, $(SSE_AVX2))
+ SSE_FLAG := -mavx2 -faligned-new -DSSE_AVX2
+ else
+@@ -71,11 +71,8 @@ ifneq (,$(findstring $(shell uname -m),
+ endif
+
POPCNT_CAPABILITY ?= 1
-else ifneq (,$(findstring $(shell uname -m), aarch64 arm64 s390x ppc64 ppc64le))
- BITS := 64
diff --git a/debian/patches/drop-not-needed-js-from-manual.patch b/debian/patches/drop-not-needed-js-from-manual.patch
index fb68ee4..90afdba 100644
--- a/debian/patches/drop-not-needed-js-from-manual.patch
+++ b/debian/patches/drop-not-needed-js-from-manual.patch
@@ -1,9 +1,9 @@
Description: Remove link to external js lib, not needed as used for ie browsers
Author: Alex Mestiashvili <amestia@rsh2.donotuse.de>
Forwarded: not-needed
---- bowtie2.orig/doc/manual.html
-+++ bowtie2/doc/manual.html
-@@ -15,9 +15,6 @@
+--- a/doc/manual.html
++++ b/doc/manual.html
+@@ -20,9 +20,6 @@
.display.math{display: block; text-align: center; margin: 0.5rem auto;}
</style>
<link rel="stylesheet" href="doc/style.css" />
diff --git a/debian/patches/hardening.patch b/debian/patches/hardening.patch
index e558619..4931103 100644
--- a/debian/patches/hardening.patch
+++ b/debian/patches/hardening.patch
@@ -5,7 +5,7 @@ Origin: Debian Med Packaging Team <debian-med-packaging@lists.alioth.debian.org>
Last-Update: Tue, 2 Jan 2018 16:20:02 +0100
--- a/Makefile
+++ b/Makefile
-@@ -293,7 +293,9 @@ DEFS := -fno-strict-aliasing \
+@@ -306,7 +306,9 @@ DEFS := -fno-strict-aliasing \
$(FILE_FLAGS) \
$(PREF_DEF) \
$(MM_DEF) \
diff --git a/debian/patches/no_sanity b/debian/patches/no_sanity
index faa9d3f..c7d09f5 100644
--- a/debian/patches/no_sanity
+++ b/debian/patches/no_sanity
@@ -2,7 +2,7 @@ Author: Michael R. Crusoe <michael.crusoe@gmail.com>
Description: save resources by not making/testing the -fsantize variants
--- a/Makefile
+++ b/Makefile
-@@ -189,15 +189,6 @@ BUILD_CPPS_MAIN := $(BUILD_CPPS) bowtie_
+@@ -202,15 +202,6 @@ BUILD_CPPS_MAIN := $(BUILD_CPPS) bowtie_
SEARCH_FRAGMENTS := $(wildcard search_*_phase*.c)
VERSION := $(shell cat BOWTIE2_VERSION)
@@ -18,7 +18,7 @@ Description: save resources by not making/testing the -fsantize variants
DEBUG_FLAGS := -O0 -g3 $(SSE_FLAG)
RELEASE_FLAGS := -O3 $(SSE_FLAG) -funroll-loops -g3
NOASSERT_FLAGS := -DNDEBUG
-@@ -217,15 +208,6 @@ BOWTIE2_BIN_LIST_DBG := bowtie2-build-s-
+@@ -230,15 +221,6 @@ BOWTIE2_BIN_LIST_DBG := bowtie2-build-s-
bowtie2-align-l-debug \
bowtie2-inspect-s-debug \
bowtie2-inspect-l-debug
@@ -34,7 +34,7 @@ Description: save resources by not making/testing the -fsantize variants
GENERAL_LIST := $(wildcard scripts/*.sh) \
$(wildcard scripts/*.pl) \
-@@ -277,10 +259,9 @@ endif
+@@ -290,10 +272,9 @@ endif
.PHONY: all allall both both-debug
all: $(BOWTIE2_BIN_LIST) ;
@@ -46,7 +46,7 @@ Description: save resources by not making/testing the -fsantize variants
DEFS := -fno-strict-aliasing \
-DBOWTIE2_VERSION="\"`cat BOWTIE2_VERSION`\"" \
-@@ -294,18 +275,11 @@ DEFS := -fno-strict-aliasing \
+@@ -307,17 +288,10 @@ DEFS := -fno-strict-aliasing \
$(CPPFLAGS) \
$(CFLAGS)
@@ -60,13 +60,12 @@ Description: save resources by not making/testing the -fsantize variants
#
# bowtie2-build targets
#
-
-bowtie2-build-s-sanitized bowtie2-build-s: bt2_build.cpp $(SHARED_CPPS) $(HEADERS)
+bowtie2-build-s: bt2_build.cpp $(SHARED_CPPS) $(HEADERS)
$(CXX) $(RELEASE_FLAGS) $(RELEASE_DEFS) $(CXXFLAGS) \
$(DEFS) -DBOWTIE2 $(NOASSERT_FLAGS) -Wall \
$(CPPFLAGS) \
-@@ -313,7 +287,7 @@ bowtie2-build-s-sanitized bowtie2-build-
+@@ -325,7 +299,7 @@ bowtie2-build-s-sanitized bowtie2-build-
$(SHARED_CPPS) $(BUILD_CPPS_MAIN) \
$(LDFLAGS) $(LDLIBS)
@@ -75,7 +74,7 @@ Description: save resources by not making/testing the -fsantize variants
$(CXX) $(RELEASE_FLAGS) $(RELEASE_DEFS) $(CXXFLAGS) \
$(DEFS) -DBOWTIE2 -DBOWTIE_64BIT_INDEX $(NOASSERT_FLAGS) -Wall \
$(CPPFLAGS) \
-@@ -341,7 +315,7 @@ bowtie2-build-l-debug: bt2_build.cpp $(S
+@@ -353,7 +327,7 @@ bowtie2-build-l-debug: bt2_build.cpp $(S
# bowtie2-align targets
#
@@ -84,7 +83,7 @@ Description: save resources by not making/testing the -fsantize variants
$(CXX) $(RELEASE_FLAGS) $(RELEASE_DEFS) $(CXXFLAGS) \
$(DEFS) -DBOWTIE2 $(NOASSERT_FLAGS) -Wall \
$(CPPFLAGS) \
-@@ -349,7 +323,7 @@ bowtie2-align-s-sanitized bowtie2-align-
+@@ -361,7 +335,7 @@ bowtie2-align-s-sanitized bowtie2-align-
$(SHARED_CPPS) $(SEARCH_CPPS_MAIN) \
$(LDFLAGS) $(LDLIBS)
@@ -93,7 +92,7 @@ Description: save resources by not making/testing the -fsantize variants
$(CXX) $(RELEASE_FLAGS) $(RELEASE_DEFS) $(CXXFLAGS) \
$(DEFS) -DBOWTIE2 -DBOWTIE_64BIT_INDEX $(NOASSERT_FLAGS) -Wall \
$(CPPFLAGS) \
-@@ -379,7 +353,7 @@ bowtie2-align-l-debug: bt2_search.cpp $(
+@@ -391,7 +365,7 @@ bowtie2-align-l-debug: bt2_search.cpp $(
# bowtie2-inspect targets
#
@@ -102,7 +101,7 @@ Description: save resources by not making/testing the -fsantize variants
$(CXX) $(RELEASE_FLAGS) \
$(RELEASE_DEFS) $(CXXFLAGS) \
$(DEFS) -DBOWTIE2 -DBOWTIE_INSPECT_MAIN -Wall \
-@@ -388,7 +362,7 @@ bowtie2-inspect-s-sanitized bowtie2-insp
+@@ -400,7 +374,7 @@ bowtie2-inspect-s-sanitized bowtie2-insp
$(SHARED_CPPS) \
$(LDFLAGS) $(LDLIBS)
@@ -111,7 +110,7 @@ Description: save resources by not making/testing the -fsantize variants
$(CXX) $(RELEASE_FLAGS) \
$(RELEASE_DEFS) $(CXXFLAGS) \
$(DEFS) -DBOWTIE2 -DBOWTIE_INSPECT_MAIN -DBOWTIE_64BIT_INDEX -Wall \
-@@ -589,7 +563,7 @@ test: simple-test
+@@ -601,7 +575,7 @@ test: simple-test
.PHONY: clean
clean:
diff --git a/debian/patches/reproducible.patch b/debian/patches/reproducible.patch
index c0cfeff..7665052 100644
--- a/debian/patches/reproducible.patch
+++ b/debian/patches/reproducible.patch
@@ -14,7 +14,7 @@ Author: Sascha Steinbiss <sascha@steinbiss.name>
BOWTIE_MM := 1
BOWTIE_SHARED_MEM :=
-@@ -205,8 +205,8 @@ DEBUG_FLAGS := -O0 -g3 $(SSE_FLAG)
+@@ -218,8 +218,8 @@ DEBUG_FLAGS := -O0 -g3 $(SSE_FLAG)
RELEASE_FLAGS := -O3 $(SSE_FLAG) -funroll-loops -g3
NOASSERT_FLAGS := -DNDEBUG
FILE_FLAGS := -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE
@@ -27,7 +27,7 @@ Author: Sascha Steinbiss <sascha@steinbiss.name>
bowtie2-build-l \
--- a/bt2_build.cpp
+++ b/bt2_build.cpp
-@@ -579,15 +579,15 @@ int bowtie_build(int argc, const char **
+@@ -580,15 +580,15 @@ int bowtie_build(int argc, const char **
} else {
cout << "Neither 32- nor 64-bit: sizeof(void*) = " << sizeof(void*) << endl;
}
@@ -81,7 +81,7 @@ Author: Sascha Steinbiss <sascha@steinbiss.name>
--- a/bt2_search.cpp
+++ b/bt2_search.cpp
-@@ -5103,15 +5103,15 @@ int bowtie(int argc, const char **argv)
+@@ -5123,15 +5123,15 @@ int bowtie(int argc, const char **argv)
} else {
cout << "Neither 32- nor 64-bit: sizeof(void*) = " << sizeof(void*) << endl;
}
@@ -90,19 +90,19 @@ Author: Sascha Steinbiss <sascha@steinbiss.name>
- cout << "Compiler: " << COMPILER_VERSION << endl;
- cout << "Options: " << COMPILER_OPTIONS << endl;
- cout << "Sizeof {int, long, long long, void*, size_t, off_t}: {"
-- << sizeof(int)
-- << ", " << sizeof(long) << ", " << sizeof(long long)
-- << ", " << sizeof(void *) << ", " << sizeof(size_t)
-- << ", " << sizeof(off_t) << "}" << endl;
-+ //cout << "Built on " << BUILD_HOST << endl;
-+ //cout << BUILD_TIME << endl;
-+ //cout << "Compiler: " << COMPILER_VERSION << endl;
-+ //cout << "Options: " << COMPILER_OPTIONS << endl;
-+ //cout << "Sizeof {int, long, long long, void*, size_t, off_t}: {"
-+ // << sizeof(int)
-+ // << ", " << sizeof(long) << ", " << sizeof(long long)
-+ // << ", " << sizeof(void *) << ", " << sizeof(size_t)
-+ // << ", " << sizeof(off_t) << "}" << endl;
+- << sizeof(int)
+- << ", " << sizeof(long) << ", " << sizeof(long long)
+- << ", " << sizeof(void *) << ", " << sizeof(size_t)
+- << ", " << sizeof(off_t) << "}" << endl;
++// cout << "Built on " << BUILD_HOST << endl;
++// cout << BUILD_TIME << endl;
++// cout << "Compiler: " << COMPILER_VERSION << endl;
++// cout << "Options: " << COMPILER_OPTIONS << endl;
++// cout << "Sizeof {int, long, long long, void*, size_t, off_t}: {"
++// << sizeof(int)
++// << ", " << sizeof(long) << ", " << sizeof(long long)
++// << ", " << sizeof(void *) << ", " << sizeof(size_t)
++// << ", " << sizeof(off_t) << "}" << endl;
return 0;
}
{
diff --git a/debian/patches/simde b/debian/patches/simde
index 120215c..24aa113 100644
--- a/debian/patches/simde
+++ b/debian/patches/simde
@@ -1,11 +1,11 @@
Author: Michael R. Crusoe <michael.crusoe@gmail.com>
Description: Enable SIMDE everywhere
---- bowtie2.orig/sse_wrap.h
-+++ bowtie2/sse_wrap.h
-@@ -27,41 +27,7 @@
- #ifndef SSE_WRAP_H_
- #define SSE_WRAP_H_
+--- a/sse_wrap.h
++++ b/sse_wrap.h
+@@ -112,44 +112,12 @@ typedef __m256i SSERegI;
+
+ #else /* no SSE_AVX2 */
-#if defined(__aarch64__) || defined(__s390x__) || defined(__powerpc__)
-#include "simde/x86/sse2.h"
@@ -13,37 +13,40 @@ Description: Enable SIMDE everywhere
-#include <emmintrin.h>
-#endif
-
+ #define NBYTES_PER_REG 16
+ #define BYTES_LOG2_PER_REG 4
+ #define SSE_MASK_ALL 0xffff
+
-#if defined(__aarch64__) || defined(__s390x__) || defined(__powerpc__)
--typedef simde__m128i __m128i;
--#define _mm_adds_epi16(x, y) simde_mm_adds_epi16(x, y)
--#define _mm_adds_epu8(x, y) simde_mm_adds_epu8(x, y)
--#define _mm_cmpeq_epi16(x, y) simde_mm_cmpeq_epi16(x, y)
--#define _mm_cmpeq_epi8(x, y) simde_mm_cmpeq_epi8(x, y)
--#define _mm_cmpgt_epi16(x, y) simde_mm_cmpgt_epi16(x, y)
--#define _mm_cmpgt_epi8(x, y) simde_mm_cmpgt_epi8(x, y)
--#define _mm_cmplt_epi16(x, y) simde_mm_cmplt_epi16(x, y)
--#define _mm_cmplt_epu8(x, y) simde_mm_cmplt_epu8(x, y)
--#define _mm_extract_epi16(x, y) simde_mm_extract_epi16(x, y)
--#define _mm_insert_epi16(x, y, z) simde_mm_insert_epi16(x, y, z)
--#define _mm_load_si128(x) simde_mm_load_si128(x)
--#define _mm_max_epi16(x, y) simde_mm_max_epi16(x, y)
--#define _mm_max_epu8(x, y) simde_mm_max_epu8(x, y)
--#define _mm_movemask_epi8(x) simde_mm_movemask_epi8(x)
--#define _mm_or_si128(x, y) simde_mm_or_si128(x, y)
--#define _mm_setzero_si128() simde_mm_setzero_si128()
--#define _mm_shuffle_epi32(x, y) simde_mm_shuffle_epi32(x, y)
--#define _mm_shufflelo_epi16(x, y) simde_mm_shufflelo_epi16(x, y)
--#define _mm_slli_epi16(x, y) simde_mm_slli_epi16(x, y)
--#define _mm_slli_si128(x, y) simde_mm_slli_si128(x, y)
--#define _mm_srli_epi16(x, y) simde_mm_srli_epi16(x, y)
--#define _mm_srli_epu8(x, y) simde_mm_srli_epu8(x, y)
--#define _mm_srli_si128(x, y) simde_mm_srli_si128(x, y)
--#define _mm_store_si128(x, y) simde_mm_store_si128(x, y)
--#define _mm_subs_epi16(x, y) simde_mm_subs_epi16(x, y)
--#define _mm_subs_epu8(x, y) simde_mm_subs_epu8(x, y)
--#define _mm_xor_si128(x, y) simde_mm_xor_si128(x, y)
--#endif
+-typedef simde__m128i SSERegI;
+-#define sse_adds_epi16(x, y) simde_mm_adds_epi16(x, y)
+-#define sse_adds_epu8(x, y) simde_mm_adds_epu8(x, y)
+-#define sse_cmpeq_epi16(x, y) simde_mm_cmpeq_epi16(x, y)
+-#define sse_cmpeq_epi8(x, y) simde_mm_cmpeq_epi8(x, y)
+-#define sse_cmpgt_epi16(x, y) simde_mm_cmpgt_epi16(x, y)
+-#define sse_cmpgt_epi8(x, y) simde_mm_cmpgt_epi8(x, y)
+-#define sse_cmplt_epi16(x, y) simde_mm_cmplt_epi16(x, y)
+-#define sse_cmplt_epu8(x, y) simde_mm_cmplt_epu8(x, y)
+-#define sse_extract_epi16(x, y) simde_mm_extract_epi16(x, y)
+-#define sse_insert_epi16(x, y, z) simde_mm_insert_epi16(x, y, z)
+-#define sse_load_siall(x) simde_mm_load_si128(x)
+-#define sse_max_epi16(x, y) simde_mm_max_epi16(x, y)
+-#define sse_max_epu8(x, y) simde_mm_max_epu8(x, y)
+-#define sse_movemask_epi8(x) simde_mm_movemask_epi8(x)
+-#define sse_or_siall(x, y) simde_mm_or_si128(x, y)
+-#define sse_setzero_siall() simde_mm_setzero_si128()
+-#define sse_slli_epi16(x, y) simde_mm_slli_epi16(x, y)
+-#define sse_slli_siall(x, y) simde_mm_slli_si128(x, y)
+-#define sse_srli_epi16(x, y) simde_mm_srli_epi16(x, y)
+-#define sse_srli_epu8(x, y) simde_mm_srli_epu8(x, y)
+-#define sse_srli_siall(x, y) simde_mm_srli_si128(x, y)
+-#define sse_store_siall(x, y) simde_mm_store_si128(x, y)
+-#define sse_subs_epi16(x, y) simde_mm_subs_epi16(x, y)
+-#define sse_subs_epu8(x, y) simde_mm_subs_epu8(x, y)
+-#define sse_xor_siall(x, y) simde_mm_xor_si128(x, y)
+-#define sse_set1_epi16(x) simde_mm_set1_epi16(x)
+#define SIMDE_ENABLE_NATIVE_ALIASES
+#include <simde/x86/sse2.h>
- #endif /* SSE_WRAP_H_ */
+ #else
+ typedef __m128i SSERegI;
diff --git a/debian/patches/skip_test_requiring_non-free_libmath-random-perl.patch b/debian/patches/skip_test_requiring_non-free_libmath-random-perl.patch
index eb8002d..aaaa0f0 100644
--- a/debian/patches/skip_test_requiring_non-free_libmath-random-perl.patch
+++ b/debian/patches/skip_test_requiring_non-free_libmath-random-perl.patch
@@ -165,7 +165,7 @@ Description: Math::Random is in package libmath-random-perl which is
print STDERR "DONE\n";
--- a/Makefile
+++ b/Makefile
-@@ -515,12 +515,12 @@ install: all
+@@ -527,12 +527,12 @@ install: all
done
.PHONY: simple-test
@@ -180,7 +180,7 @@ Description: Math::Random is in package libmath-random-perl which is
eval `perl -I $(CURDIR)/.tmp/lib/perl5 -Mlocal::lib=$(CURDIR)/.tmp` ; \
sh ./scripts/sim/run.sh $(if $(NUM_CORES), $(NUM_CORES), 2)
-@@ -531,8 +531,7 @@ perl-deps:
+@@ -543,8 +543,7 @@ perl-deps:
fi
DL=$$( ( which wget >/dev/null 2>&1 && echo "wget --no-check-certificate -O-" ) || echo "curl -L") ; \
$$DL http://cpanmin.us | perl - -l $(CURDIR)/.tmp App::cpanminus local::lib ; \
@@ -190,7 +190,7 @@ Description: Math::Random is in package libmath-random-perl which is
.PHONY: static-libs
static-libs:
-@@ -589,7 +588,7 @@ sra-deps:
+@@ -601,7 +600,7 @@ sra-deps:
fi ;
.PHONY: test
diff --git a/debian/patches/use-source-date-epoch-in-Makefile.patch b/debian/patches/use-source-date-epoch-in-Makefile.patch
index 1eb4902..e49bb2e 100644
--- a/debian/patches/use-source-date-epoch-in-Makefile.patch
+++ b/debian/patches/use-source-date-epoch-in-Makefile.patch
@@ -7,7 +7,7 @@ https://reproducible-builds.org/docs/source-date-epoch/
--- a/Makefile
+++ b/Makefile
-@@ -266,7 +266,7 @@ both-debug: bowtie2-align-s-debug bowtie
+@@ -279,7 +279,7 @@ both-debug: bowtie2-align-s-debug bowtie
DEFS := -fno-strict-aliasing \
-DBOWTIE2_VERSION="\"`cat BOWTIE2_VERSION`\"" \
-DBUILD_HOST="\"$${HOSTNAME:-`hostname`}\"" \