summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorAndreas Tille <tille@debian.org>2012-02-21 20:55:31 +0100
committerAndreas Tille <tille@debian.org>2012-02-21 20:55:31 +0100
commitc7c402a1f85d7a9d9726c869dfb0ac36ef594360 (patch)
tree98757a69efaae6f7391aa75ffadd7826a4ef1a33 /debian/rules
parent4cbe5c0bcda26d66da8fc5a4b77654701ef32de6 (diff)
More elegant way to specify package name, hope you like this - feel free to revert this suggestion
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules14
1 files changed, 7 insertions, 7 deletions
diff --git a/debian/rules b/debian/rules
index 955b638..7930ff2 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,21 +1,21 @@
#!/usr/bin/make -f
-pkg=bowtie2
+pkg=$(shell dpkg-parsechangelog | sed -n 's/^Source: //p')
%:
dh $@
override_dh_auto_install:
mkdir -p $(CURDIR)/debian/$(pkg)/usr/share/man/man1/
- for bin in bowtie2 bowtie2-build bowtie2-inspect bowtie2-align; do \
+ for bin in $(pkg) $(pkg)-build $(pkg)-inspect $(pkg)-align; do \
help2man $(CURDIR)/$${bin} > $(CURDIR)/debian/$(pkg)/usr/share/man/man1/$${bin}.1 ; \
done
help2man --name="ultrafast memory-efficient short read aligner" --no-info \
- $(CURDIR)/bowtie2 > $(CURDIR)/debian/$(pkg)/usr/share/man/man1/bowtie2.1
- help2man --name="building a colorspace index for bowtie2" --no-info \
- $(CURDIR)/bowtie2-build > $(CURDIR)/debian/$(pkg)/usr/share/man/man1/bowtie2-build.1
- help2man --name="extracts information from a bowtie2 index" --no-info \
- $(CURDIR)/bowtie2-inspect > $(CURDIR)/debian/$(pkg)/usr/share/man/man1/bowtie2-inspect.1
+ $(CURDIR)/$(pkg) > $(CURDIR)/debian/$(pkg)/usr/share/man/man1/$(pkg).1
+ help2man --name="building a colorspace index for $(pkg)" --no-info \
+ $(CURDIR)/$(pkg)-build > $(CURDIR)/debian/$(pkg)/usr/share/man/man1/$(pkg)-build.1
+ help2man --name="extracts information from a $(pkg) index" --no-info \
+ $(CURDIR)/$(pkg)-inspect > $(CURDIR)/debian/$(pkg)/usr/share/man/man1/$(pkg)-inspect.1
get-orig-source:
. debian/get-orig-source