summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorAndreas Tille <tille@debian.org>2020-05-25 14:14:12 +0200
committerAndreas Tille <tille@debian.org>2020-05-25 14:14:12 +0200
commit97052bc2de1b271f368dd8415cfafde5356e2fe8 (patch)
treeecf209c271d555f252bf571789e19ab6dc1559be /debian
parente3f843bc9079b4df01c629296f7aa69fd202de24 (diff)
Reproducible builds: filter out -ffile-prefix-map
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog7
-rw-r--r--debian/patches/reproducible.patch37
2 files changed, 26 insertions, 18 deletions
diff --git a/debian/changelog b/debian/changelog
index 4aea89a..09e9ac2 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+bowtie2 (2.4.1-5) UNRELEASED; urgency=medium
+
+ * Reproducible builds: filter out -ffile-prefix-map
+ Closes: #961494
+
+ -- Andreas Tille <tille@debian.org> Mon, 25 May 2020 14:13:25 +0200
+
bowtie2 (2.4.1-4) unstable; urgency=medium
* Team upload.
diff --git a/debian/patches/reproducible.patch b/debian/patches/reproducible.patch
index d9d88f0..ba70db7 100644
--- a/debian/patches/reproducible.patch
+++ b/debian/patches/reproducible.patch
@@ -3,9 +3,9 @@ Description: make build reproducible
hostname, time, etc. from the binary. It also ensures a stable
sorting order for all wildcard expansions in the Makefile.
Author: Sascha Steinbiss <sascha@steinbiss.name>
---- bowtie2.orig/Makefile
-+++ bowtie2/Makefile
-@@ -31,7 +31,7 @@
+--- a/Makefile
++++ b/Makefile
+@@ -31,7 +31,7 @@ CC ?= $(GCC_PREFIX)/gcc$(GCC_SUFFIX)
CPP ?= $(GCC_PREFIX)/g++$(GCC_SUFFIX)
CXX ?= $(CPP)
@@ -14,20 +14,20 @@ Author: Sascha Steinbiss <sascha@steinbiss.name>
BOWTIE_MM := 1
BOWTIE_SHARED_MEM :=
-@@ -236,8 +236,8 @@
+@@ -236,8 +236,8 @@ DEBUG_FLAGS := -O0 -g3 $(SSE_FLAG)
RELEASE_FLAGS := -O3 $(SSE_FLAG) -funroll-loops -g3
NOASSERT_FLAGS := -DNDEBUG
FILE_FLAGS := -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE
-DEBUG_DEFS = -DCOMPILER_OPTIONS="\"$(DEBUG_FLAGS) $(CXXFLAGS)\""
-RELEASE_DEFS = -DCOMPILER_OPTIONS="\"$(RELEASE_FLAGS) $(CXXFLAGS)\""
-+DEBUG_DEFS = -DCOMPILER_OPTIONS="\"$(filter-out -fdebug-prefix-map=%,$(DEBUG_FLAGS) $(CXXFLAGS))\""
-+RELEASE_DEFS = -DCOMPILER_OPTIONS="\"$(filter-out -fdebug-prefix-map=%,$(RELEASE_FLAGS) $(CXXFLAGS))\""
++DEBUG_DEFS = -DCOMPILER_OPTIONS="\"$(filter-out -fdebug-prefix-map=% -ffile-prefix-map=%,$(DEBUG_FLAGS) $(CXXFLAGS))\""
++RELEASE_DEFS = -DCOMPILER_OPTIONS="\"$(filter-out -fdebug-prefix-map=% -ffile-prefix-map=%,$(RELEASE_FLAGS) $(CXXFLAGS))\""
BOWTIE2_BIN_LIST := bowtie2-build-s \
bowtie2-build-l \
---- bowtie2.orig/bt2_build.cpp
-+++ bowtie2/bt2_build.cpp
-@@ -561,15 +561,15 @@
+--- a/bt2_build.cpp
++++ b/bt2_build.cpp
+@@ -561,15 +561,15 @@ int bowtie_build(int argc, const char **
} else {
cout << "Neither 32- nor 64-bit: sizeof(void*) = " << sizeof(void*) << endl;
}
@@ -52,9 +52,9 @@ Author: Sascha Steinbiss <sascha@steinbiss.name>
return 0;
}
---- bowtie2.orig/bt2_inspect.cpp
-+++ bowtie2/bt2_inspect.cpp
-@@ -445,15 +445,15 @@
+--- a/bt2_inspect.cpp
++++ b/bt2_inspect.cpp
+@@ -445,15 +445,15 @@ int main(int argc, char **argv) {
} else {
cout << "Neither 32- nor 64-bit: sizeof(void*) = " << sizeof(void*) << endl;
}
@@ -79,9 +79,9 @@ Author: Sascha Steinbiss <sascha@steinbiss.name>
return 0;
}
---- bowtie2.orig/bt2_search.cpp
-+++ bowtie2/bt2_search.cpp
-@@ -5145,15 +5145,15 @@
+--- a/bt2_search.cpp
++++ b/bt2_search.cpp
+@@ -5145,15 +5145,15 @@ int bowtie(int argc, const char **argv)
} else {
cout << "Neither 32- nor 64-bit: sizeof(void*) = " << sizeof(void*) << endl;
}
@@ -106,14 +106,15 @@ Author: Sascha Steinbiss <sascha@steinbiss.name>
return 0;
}
{
---- bowtie2.orig/CMakeLists.txt
-+++ bowtie2/CMakeLists.txt
-@@ -275,7 +275,8 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -275,7 +275,9 @@ endif()
include_directories(${PROJECT_SOURCE_DIR})
get_directory_property(COMPILER_DEFS COMPILE_DEFINITIONS)
-add_definitions(-DCOMPILER_OPTIONS="${CMAKE_CXX_FLAGS}")
+string(REGEX REPLACE "-fdebug-prefix-map=[^ ]* " "" COMP_OPTS ${CMAKE_CXX_FLAGS})
++string(REGEX REPLACE "-ffile-prefix-map=[^ ]* " "" COMP_OPTS ${COMP_OPTS})
+add_definitions(-DCOMPILER_OPTIONS="${COMP_OPTS}")
add_executable(bowtie2-align-s ${SEARCH_CPPS} ${SHARED_CPPS})