summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile26
1 files changed, 19 insertions, 7 deletions
diff --git a/Makefile b/Makefile
index 9c01b72..68f95d4 100644
--- a/Makefile
+++ b/Makefile
@@ -64,7 +64,12 @@ endif
BITS := 32
ifneq (,$(findstring $(shell uname -m), x86_64 amd64))
BITS := 64
- SSE_FLAG := -msse2
+ ifeq (1, $(SSE_AVX2))
+ SSE_FLAG := -mavx2 -faligned-new -DSSE_AVX2
+ else
+ SSE_FLAG := -msse2
+ endif
+
POPCNT_CAPABILITY ?= 1
else ifneq (,$(findstring $(shell uname -m), aarch64 arm64 s390x ppc64 ppc64le))
BITS := 64
@@ -74,6 +79,13 @@ else ifneq (,$(findstring $(shell uname -m), aarch64 arm64 s390x ppc64 ppc64le))
POPCNT_CAPABILITY ?= 0
endif
+ifdef USE_SAIS
+ CPPFLAGS += -Ithird_party/libsais/include
+ CXXFLAGS += -fopenmp -DUSE_SAIS
+ LDFLAGS += -Lthird_party/libsais/lib
+ LDLIBS += -lsais
+endif
+
# msys will always be 32 bit so look at the cpu arch instead.
ifneq (,$(findstring AMD64,$(PROCESSOR_ARCHITEW6432)))
ifeq (1,$(MINGW))
@@ -176,6 +188,7 @@ SEARCH_CPPS := qual.cpp pat.cpp sam.cpp \
ifeq (1, $(WITH_ZSTD))
LDLIBS += -lzstd
+ CXXFLAGS += -DWITH_ZSTD
SHARED_CPPS += zstd_decompress.cpp
endif
@@ -305,7 +318,6 @@ endif
#
# bowtie2-build targets
#
-
bowtie2-build-s-sanitized bowtie2-build-s: bt2_build.cpp $(SHARED_CPPS) $(HEADERS)
$(CXX) $(RELEASE_FLAGS) $(RELEASE_DEFS) $(CXXFLAGS) \
$(DEFS) -DBOWTIE2 $(NOASSERT_FLAGS) -Wall \
@@ -544,16 +556,16 @@ static-libs:
cd $(CURDIR)/.tmp ; \
DL=$$( ( which wget >/dev/null 2>&1 && echo "wget --no-check-certificate" ) || echo "curl -LOk") ; \
if [ ! -f "$(CURDIR)/.tmp/include/zlib.h" ] ; then \
- $$DL https://zlib.net/zlib-1.2.11.tar.gz && tar xzf zlib-1.2.11.tar.gz && cd zlib-1.2.11 ; \
+ $$DL https://zlib.net/zlib-1.2.13.tar.gz && tar xzf zlib-1.2.13.tar.gz && cd zlib-1.2.13 ; \
$(if $(MINGW), mingw32-make -f win32/Makefile.gcc, ./configure --static && make) ; \
cp zlib.h zconf.h $(CURDIR)/.tmp/include && cp libz.a $(CURDIR)/.tmp/lib ; \
- rm -f zlib-1.2.11 ; \
+ rm -f zlib-1.2.13 ; \
fi ; \
if [ ! -f "$(CURDIR)/.tmp/include/zstd.h" ]; then \
cd $(CURDIR)/.tmp ; \
- $$DL https://github.com/facebook/zstd/releases/download/v1.4.9/zstd-1.4.9.tar.gz && tar xzf zstd-1.4.9.tar.gz ; \
- cd zstd-1.4.9 && $(MAKE) ; \
- cd $(CURDIR)/.tmp/zstd-1.4.9/lib && cp zstd.h $(CURDIR)/.tmp/include && cp libzstd.a $(CURDIR)/.tmp/lib ; \
+ $$DL https://github.com/facebook/zstd/releases/download/v1.5.1/zstd-1.5.1.tar.gz && tar xzf zstd-1.5.1.tar.gz ; \
+ cd zstd-1.5.1 && $(MAKE) lib ; \
+ cd $(CURDIR)/.tmp/zstd-1.5.1/lib && cp zstd.h $(CURDIR)/.tmp/include && cp libzstd.a $(CURDIR)/.tmp/lib ; \
fi
.PHONY: sra-deps