summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Wilson <chris+github@qwirx.com>2010-01-24 14:24:24 +0000
committerChris Wilson <chris+github@qwirx.com>2010-01-24 14:24:24 +0000
commit39f209f9edc67332a284f46ecee8f7c27f606245 (patch)
treeafcd74afc9049949c620e8c39c21d8653ee30d15
parent9cbf4791fc4cbf3e0cfe375b285ea998fae2536d (diff)
Run Perl scripts quietly during make.
-rw-r--r--bin/bbackupd/Makefile.extra2
-rw-r--r--bin/bbackupquery/Makefile.extra2
-rw-r--r--bin/bbstored/Makefile.extra2
-rwxr-xr-xinfrastructure/makebuildenv.pl.in5
-rw-r--r--lib/backupclient/Makefile.extra4
-rw-r--r--lib/common/Makefile.extra4
-rw-r--r--lib/compress/Makefile.extra2
-rw-r--r--lib/crypto/Makefile.extra2
-rw-r--r--lib/httpserver/Makefile.extra2
-rw-r--r--lib/raidfile/Makefile.extra2
-rw-r--r--lib/server/Makefile.extra4
-rw-r--r--test/basicserver/Makefile.extra8
12 files changed, 21 insertions, 18 deletions
diff --git a/bin/bbackupd/Makefile.extra b/bin/bbackupd/Makefile.extra
index 52e21366..25ceb1e7 100644
--- a/bin/bbackupd/Makefile.extra
+++ b/bin/bbackupd/Makefile.extra
@@ -3,5 +3,5 @@ MAKEEXCEPTION = ../../lib/common/makeexception.pl
# AUTOGEN SEEDING
autogen_ClientException.h autogen_ClientException.cpp: $(MAKEEXCEPTION) ClientException.txt
- $(PERL) $(MAKEEXCEPTION) ClientException.txt
+ $(_PERL) $(MAKEEXCEPTION) ClientException.txt
diff --git a/bin/bbackupquery/Makefile.extra b/bin/bbackupquery/Makefile.extra
index f347c451..e1049b6d 100644
--- a/bin/bbackupquery/Makefile.extra
+++ b/bin/bbackupquery/Makefile.extra
@@ -1,6 +1,6 @@
# AUTOGEN SEEDING
autogen_Documentation.cpp: makedocumentation.pl documentation.txt
- $(PERL) makedocumentation.pl
+ $(_PERL) makedocumentation.pl
diff --git a/bin/bbstored/Makefile.extra b/bin/bbstored/Makefile.extra
index 94bc3fb9..6562647d 100644
--- a/bin/bbstored/Makefile.extra
+++ b/bin/bbstored/Makefile.extra
@@ -5,5 +5,5 @@ GEN_CMD_SRV = $(MAKEPROTOCOL) Server backupprotocol.txt
# AUTOGEN SEEDING
autogen_BackupProtocolServer.cpp autogen_BackupProtocolServer.h: $(MAKEPROTOCOL) backupprotocol.txt
- $(PERL) $(GEN_CMD_SRV)
+ $(_PERL) $(GEN_CMD_SRV)
diff --git a/infrastructure/makebuildenv.pl.in b/infrastructure/makebuildenv.pl.in
index 1b2f87e7..8b6f61a3 100755
--- a/infrastructure/makebuildenv.pl.in
+++ b/infrastructure/makebuildenv.pl.in
@@ -55,7 +55,7 @@ while(<FINDAUTOGEN>)
my $dir = $1;
open FL,$file or die "Can't open $_ for reading";
my %vars;
- $vars{PERL} = "@PERL@";
+ $vars{_PERL} = "@PERL@";
my $do_cmds = 0;
while(<FL>)
{
@@ -590,6 +590,7 @@ _LINK = \$(CXX)
_WINDRES = \$(WINDRES)
_AR = \$(AR)
_RANLIB = \$(RANLIB)
+_PERL = \$(PERL)
.else
HIDE = @
_CXX = @ echo " [CXX] " \$(*F) && \$(CXX)
@@ -597,6 +598,7 @@ _LINK = @ echo " [LINK] " \$(*F) && \$(CXX)
_WINDRES = @ echo " [WINDRES]" \$(*F) && \$(WINDRES)
_AR = @ echo " [AR] " \$(*F) && \$(AR)
_RANLIB = @ echo " [RANLIB] " \$(*F) && \$(RANLIB)
+_PERL = @ echo " [PERL] " \$(*F) && \$(PERL)
.endif
__E
@@ -610,6 +612,7 @@ _LINK = \$(if \$(V),\$(CXX), @ echo " [LINK] \$@" && \$(CXX))
_WINDRES = \$(if \$(V),\$(WINDRES), @ echo " [WINDRES] \$<" && \$(WINDRES))
_AR = \$(if \$(V),\$(AR), @ echo " [AR] \$@" && \$(AR))
_RANLIB = \$(if \$(V),\$(RANLIB), @ echo " [RANLIB] \$@" && \$(RANLIB))
+_PERL = \$(if \$(V),\$(PERL), @ echo " [PERL] \$@" && \$(PERL))
__E
}
diff --git a/lib/backupclient/Makefile.extra b/lib/backupclient/Makefile.extra
index 925c880e..df3319df 100644
--- a/lib/backupclient/Makefile.extra
+++ b/lib/backupclient/Makefile.extra
@@ -5,12 +5,12 @@ GEN_CMD_SRV = $(MAKEPROTOCOL) Client ../../bin/bbstored/backupprotocol.txt
# AUTOGEN SEEDING
autogen_BackupProtocolClient.cpp autogen_BackupProtocolClient.h: $(MAKEPROTOCOL) ../../bin/bbstored/backupprotocol.txt
- $(PERL) $(GEN_CMD_SRV)
+ $(_PERL) $(GEN_CMD_SRV)
MAKEEXCEPTION = ../../lib/common/makeexception.pl
# AUTOGEN SEEDING
autogen_BackupStoreException.h autogen_BackupStoreException.cpp: $(MAKEEXCEPTION) BackupStoreException.txt
- $(PERL) $(MAKEEXCEPTION) BackupStoreException.txt
+ $(_PERL) $(MAKEEXCEPTION) BackupStoreException.txt
diff --git a/lib/common/Makefile.extra b/lib/common/Makefile.extra
index 04dd8e71..cc3f3a7a 100644
--- a/lib/common/Makefile.extra
+++ b/lib/common/Makefile.extra
@@ -3,9 +3,9 @@ MAKEEXCEPTION = ../../lib/common/makeexception.pl
# AUTOGEN SEEDING
autogen_CommonException.h autogen_CommonException.cpp: $(MAKEEXCEPTION) CommonException.txt
- $(PERL) $(MAKEEXCEPTION) CommonException.txt
+ $(_PERL) $(MAKEEXCEPTION) CommonException.txt
# AUTOGEN SEEDING
autogen_ConversionException.h autogen_ConversionException.cpp: $(MAKEEXCEPTION) ConversionException.txt
- $(PERL) $(MAKEEXCEPTION) ConversionException.txt
+ $(_PERL) $(MAKEEXCEPTION) ConversionException.txt
diff --git a/lib/compress/Makefile.extra b/lib/compress/Makefile.extra
index 3598f1c9..a29fcdb4 100644
--- a/lib/compress/Makefile.extra
+++ b/lib/compress/Makefile.extra
@@ -3,5 +3,5 @@ MAKEEXCEPTION = ../../lib/common/makeexception.pl
# AUTOGEN SEEDING
autogen_CompressException.h autogen_CompressException.cpp: $(MAKEEXCEPTION) CompressException.txt
- $(PERL) $(MAKEEXCEPTION) CompressException.txt
+ $(_PERL) $(MAKEEXCEPTION) CompressException.txt
diff --git a/lib/crypto/Makefile.extra b/lib/crypto/Makefile.extra
index f9d63a42..3c94389f 100644
--- a/lib/crypto/Makefile.extra
+++ b/lib/crypto/Makefile.extra
@@ -3,5 +3,5 @@ MAKEEXCEPTION = ../../lib/common/makeexception.pl
# AUTOGEN SEEDING
autogen_CipherException.cpp autogen_CipherException.h: $(MAKEEXCEPTION) CipherException.txt
- $(PERL) $(MAKEEXCEPTION) CipherException.txt
+ $(_PERL) $(MAKEEXCEPTION) CipherException.txt
diff --git a/lib/httpserver/Makefile.extra b/lib/httpserver/Makefile.extra
index f0ca62be..ef47f398 100644
--- a/lib/httpserver/Makefile.extra
+++ b/lib/httpserver/Makefile.extra
@@ -3,5 +3,5 @@ MAKEEXCEPTION = ../../lib/common/makeexception.pl
# AUTOGEN SEEDING
autogen_HTTPException.h autogen_HTTPException.cpp: $(MAKEEXCEPTION) HTTPException.txt
- perl $(MAKEEXCEPTION) HTTPException.txt
+ $(_PERL) $(MAKEEXCEPTION) HTTPException.txt
diff --git a/lib/raidfile/Makefile.extra b/lib/raidfile/Makefile.extra
index 4d904e8a..bf06ed2f 100644
--- a/lib/raidfile/Makefile.extra
+++ b/lib/raidfile/Makefile.extra
@@ -3,5 +3,5 @@ MAKEEXCEPTION = ../../lib/common/makeexception.pl
# AUTOGEN SEEDING
autogen_RaidFileException.h autogen_RaidFileException.cpp: $(MAKEEXCEPTION) RaidFileException.txt
- $(PERL) $(MAKEEXCEPTION) RaidFileException.txt
+ $(_PERL) $(MAKEEXCEPTION) RaidFileException.txt
diff --git a/lib/server/Makefile.extra b/lib/server/Makefile.extra
index 33fac0a1..7fc6baf9 100644
--- a/lib/server/Makefile.extra
+++ b/lib/server/Makefile.extra
@@ -3,9 +3,9 @@ MAKEEXCEPTION = ../../lib/common/makeexception.pl
# AUTOGEN SEEDING
autogen_ServerException.h autogen_ServerException.cpp: $(MAKEEXCEPTION) ServerException.txt
- $(PERL) $(MAKEEXCEPTION) ServerException.txt
+ $(_PERL) $(MAKEEXCEPTION) ServerException.txt
# AUTOGEN SEEDING
autogen_ConnectionException.h autogen_ConnectionException.cpp: $(MAKEEXCEPTION) ConnectionException.txt
- $(PERL) $(MAKEEXCEPTION) ConnectionException.txt
+ $(_PERL) $(MAKEEXCEPTION) ConnectionException.txt
diff --git a/test/basicserver/Makefile.extra b/test/basicserver/Makefile.extra
index 3feda961..50120136 100644
--- a/test/basicserver/Makefile.extra
+++ b/test/basicserver/Makefile.extra
@@ -6,16 +6,16 @@ GEN_CMD_CLI = $(MAKEPROTOCOL) Client testprotocol.txt
# AUTOGEN SEEDING
autogen_TestProtocolServer.cpp: $(MAKEPROTOCOL) testprotocol.txt
- $(PERL) $(GEN_CMD_SRV)
+ $(_PERL) $(GEN_CMD_SRV)
autogen_TestProtocolServer.h: $(MAKEPROTOCOL) testprotocol.txt
- $(PERL) $(GEN_CMD_SRV)
+ $(_PERL) $(GEN_CMD_SRV)
# AUTOGEN SEEDING
autogen_TestProtocolClient.cpp: $(MAKEPROTOCOL) testprotocol.txt
- $(PERL) $(GEN_CMD_CLI)
+ $(_PERL) $(GEN_CMD_CLI)
autogen_TestProtocolClient.h: $(MAKEPROTOCOL) testprotocol.txt
- $(PERL) $(GEN_CMD_CLI)
+ $(_PERL) $(GEN_CMD_CLI)