summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Wilson <chris+github@qwirx.com>2014-12-01 10:33:57 +0000
committerChris Wilson <chris+github@qwirx.com>2014-12-01 10:33:57 +0000
commit85e6190fae2f79d34404ea09bfe4140be6382b17 (patch)
tree1371dc893741e11852b34f427b4eb9c828df6baa
parent7b0113375b86770412922a4b7adb001e2e01c0d4 (diff)
Generate configure script in qdbm directory.
Now that we've removed it from version control, we need to build it from configure.in as part of bootstrapping Box Backup.
-rwxr-xr-xbootstrap1
-rw-r--r--infrastructure/m4/boxbackup_tests.m44
-rw-r--r--lib/server/SocketStream.h4
3 files changed, 7 insertions, 2 deletions
diff --git a/bootstrap b/bootstrap
index 14fc19e3..b669c409 100755
--- a/bootstrap
+++ b/bootstrap
@@ -3,3 +3,4 @@
aclocal -I infrastructure/m4
autoheader
autoconf
+(cd qdbm; autoconf)
diff --git a/infrastructure/m4/boxbackup_tests.m4 b/infrastructure/m4/boxbackup_tests.m4
index 14902809..8bc13883 100644
--- a/infrastructure/m4/boxbackup_tests.m4
+++ b/infrastructure/m4/boxbackup_tests.m4
@@ -136,8 +136,8 @@ AC_HEADER_SYS_WAIT
AC_CHECK_HEADERS([dlfcn.h fcntl.h getopt.h process.h pwd.h signal.h])
AC_CHECK_HEADERS([syslog.h time.h cxxabi.h])
AC_CHECK_HEADERS([netinet/in.h netinet/tcp.h])
-AC_CHECK_HEADERS([sys/file.h sys/param.h sys/socket.h sys/time.h sys/types.h])
-AC_CHECK_HEADERS([sys/uio.h sys/un.h sys/wait.h sys/xattr.h])
+AC_CHECK_HEADERS([sys/file.h sys/param.h sys/poll.h sys/socket.h sys/time.h])
+AC_CHECK_HEADERS([sys/types.h sys/uio.h sys/un.h sys/wait.h sys/xattr.h])
AC_CHECK_HEADERS([bsd/unistd.h])
AC_CHECK_HEADERS([sys/socket.h], [have_sys_socket_h=yes])
AC_CHECK_HEADERS([winsock2.h], [have_winsock2_h=yes])
diff --git a/lib/server/SocketStream.h b/lib/server/SocketStream.h
index c3a67cb0..8b5e322d 100644
--- a/lib/server/SocketStream.h
+++ b/lib/server/SocketStream.h
@@ -12,6 +12,10 @@
#include <climits>
+#ifdef HAVE_SYS_POLL_H
+# include <sys/poll.h>
+#endif
+
#include "BoxTime.h"
#include "IOStream.h"
#include "Socket.h"