summaryrefslogtreecommitdiff
path: root/infrastructure/cmake/CMakeLists.txt
diff options
context:
space:
mode:
authorReinhard Tartler <siretart@tauware.de>2019-03-10 14:10:09 -0400
committerReinhard Tartler <siretart@tauware.de>2019-03-10 14:10:09 -0400
commit1b839d11810d6202f9b6f41db8f0ec3197e6a867 (patch)
tree356521966aeadbf4265d6fafa163bb12ea0075ec /infrastructure/cmake/CMakeLists.txt
parentc84f07d33496f2c0c6553c70991581c2bdc75e52 (diff)
New upstream version 0.13~~git20180819.g2f5b556
Diffstat (limited to 'infrastructure/cmake/CMakeLists.txt')
-rw-r--r--infrastructure/cmake/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/infrastructure/cmake/CMakeLists.txt b/infrastructure/cmake/CMakeLists.txt
index e6f46148..5116e7ff 100644
--- a/infrastructure/cmake/CMakeLists.txt
+++ b/infrastructure/cmake/CMakeLists.txt
@@ -451,6 +451,11 @@ else()
include_directories(${PCRE_INCLUDE_DIRS})
target_link_libraries(lib_common PUBLIC ${PCRE_LIBRARIES})
+ if(NOT PCRE_FOUND)
+ # You must use pkg-config. PCRE_ROOT is not used except on Win32.
+ message(FATAL_ERROR "Please install libpcre and ensure that pkg-config --list-all can find it")
+ endif()
+
if(DEBUG)
message(STATUS "Linking PCRE libraries from ${PCRE_LIBRARY_DIRS}: ${PCRE_LIBRARIES}")
endif()
@@ -594,7 +599,7 @@ foreach(header_file ${detect_header_files})
endforeach()
if(NOT HAVE_PCREPOSIX_H)
- message(FATAL_ERROR "pcreposix.h not found at PCRE_ROOT/include: ${PCRE_ROOT}/include")
+ message(FATAL_ERROR "pcreposix.h not found even though PCRE was apparently detected?!")
endif()
# PCRE is required, so unconditionally define this: