summaryrefslogtreecommitdiff
path: root/infrastructure/cmake
diff options
context:
space:
mode:
authorChris Wilson <chris+github@qwirx.com>2015-12-09 22:55:08 +0000
committerChris Wilson <chris+github@qwirx.com>2015-12-09 22:55:08 +0000
commite5cf6b96f5192293f5505f4086e20fd658666a4a (patch)
treeb3d37873123661bb4bcdc714d2916a7c9c5d3725 /infrastructure/cmake
parent8284254f2a9975d663b312f43253a53c40f57cef (diff)
Hide copious warnings about spurious memory leaks
Diffstat (limited to 'infrastructure/cmake')
-rw-r--r--infrastructure/cmake/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/infrastructure/cmake/CMakeLists.txt b/infrastructure/cmake/CMakeLists.txt
index 80c136f1..c9701607 100644
--- a/infrastructure/cmake/CMakeLists.txt
+++ b/infrastructure/cmake/CMakeLists.txt
@@ -201,7 +201,7 @@ target_compile_definitions(qdbm PUBLIC -DQDBM_STATIC)
# Silence some less-useful warnings
if(MSVC)
- add_definitions(/wd4996)
+ add_definitions(/wd4996 /wd4291)
# target_link_libraries(qdbm PRIVATE /IGNORE:LNK4006)
set_property(TARGET qdbm PROPERTY CMAKE_STATIC_LINKER_FLAGS /IGNORE:LNK4006)
endif(MSVC)