summaryrefslogtreecommitdiff
path: root/infrastructure
diff options
context:
space:
mode:
authorChris Wilson <chris+github@qwirx.com>2015-12-09 22:33:12 +0000
committerChris Wilson <chris+github@qwirx.com>2015-12-09 22:33:12 +0000
commit00a5a49f1887236bc1de5adebcd77be03a6b13a0 (patch)
tree9d8c950438755e1825fa5563935eef2c4f3e514f /infrastructure
parente2e1fcd3ef141aefa4c458c5e811365ee02aaa35 (diff)
Find ZLib library and link to it.
Diffstat (limited to 'infrastructure')
-rw-r--r--infrastructure/cmake/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/infrastructure/cmake/CMakeLists.txt b/infrastructure/cmake/CMakeLists.txt
index ccb4b4c8..23623eb2 100644
--- a/infrastructure/cmake/CMakeLists.txt
+++ b/infrastructure/cmake/CMakeLists.txt
@@ -186,6 +186,11 @@ endif(MSVC)
target_link_libraries(lib_common PUBLIC ws2_32 gdi32)
+# Link to ZLib
+include_directories(${base_dir}/../zlib-win32/include)
+find_library(zlibstaticd_lib_path zlibstaticd ${base_dir}/../zlib-win32/lib)
+target_link_libraries(lib_compress PUBLIC ${zlibstaticd_lib_path})
+
# Link to OpenSSL
include_directories(${base_dir}/../openssl-win32/include)
find_library(libeay32_lib_path libeay32 ${base_dir}/../openssl-win32/lib)