summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index c6b27fea..5ce21491 100644
--- a/configure.ac
+++ b/configure.ac
@@ -84,9 +84,13 @@ Upgrade or read the documentation for alternatives]])
### Checks for header files.
-if test "$target_os" != "mingw32"; then
+case $target_os in
+mingw32*) ;;
+winnt*) ;;
+*)
AC_HEADER_DIRENT
-fi
+ ;;
+esac
AC_HEADER_STDC
AC_HEADER_SYS_WAIT