summaryrefslogtreecommitdiff
path: root/lib
diff options
context:
space:
mode:
Diffstat (limited to 'lib')
-rw-r--r--lib/backupclient/Makefile.extra4
-rw-r--r--lib/common/Makefile.extra4
-rwxr-xr-xlib/common/makeexception.pl2
-rw-r--r--lib/compress/Makefile.extra2
-rw-r--r--lib/crypto/Makefile.extra2
-rw-r--r--lib/raidfile/Makefile.extra2
-rwxr-xr-xlib/raidfile/raidfile-config2
-rw-r--r--lib/server/Makefile.extra4
-rwxr-xr-xlib/server/makeprotocol.pl2
9 files changed, 12 insertions, 12 deletions
diff --git a/lib/backupclient/Makefile.extra b/lib/backupclient/Makefile.extra
index 66203e3c..925c880e 100644
--- a/lib/backupclient/Makefile.extra
+++ b/lib/backupclient/Makefile.extra
@@ -5,12 +5,12 @@ GEN_CMD_SRV = $(MAKEPROTOCOL) Client ../../bin/bbstored/backupprotocol.txt
# AUTOGEN SEEDING
autogen_BackupProtocolClient.cpp autogen_BackupProtocolClient.h: $(MAKEPROTOCOL) ../../bin/bbstored/backupprotocol.txt
- perl $(GEN_CMD_SRV)
+ $(PERL) $(GEN_CMD_SRV)
MAKEEXCEPTION = ../../lib/common/makeexception.pl
# AUTOGEN SEEDING
autogen_BackupStoreException.h autogen_BackupStoreException.cpp: $(MAKEEXCEPTION) BackupStoreException.txt
- perl $(MAKEEXCEPTION) BackupStoreException.txt
+ $(PERL) $(MAKEEXCEPTION) BackupStoreException.txt
diff --git a/lib/common/Makefile.extra b/lib/common/Makefile.extra
index 92e6fbb3..04dd8e71 100644
--- a/lib/common/Makefile.extra
+++ b/lib/common/Makefile.extra
@@ -3,9 +3,9 @@ MAKEEXCEPTION = ../../lib/common/makeexception.pl
# AUTOGEN SEEDING
autogen_CommonException.h autogen_CommonException.cpp: $(MAKEEXCEPTION) CommonException.txt
- perl $(MAKEEXCEPTION) CommonException.txt
+ $(PERL) $(MAKEEXCEPTION) CommonException.txt
# AUTOGEN SEEDING
autogen_ConversionException.h autogen_ConversionException.cpp: $(MAKEEXCEPTION) ConversionException.txt
- perl $(MAKEEXCEPTION) ConversionException.txt
+ $(PERL) $(MAKEEXCEPTION) ConversionException.txt
diff --git a/lib/common/makeexception.pl b/lib/common/makeexception.pl
index c0388286..1564b75b 100755
--- a/lib/common/makeexception.pl
+++ b/lib/common/makeexception.pl
@@ -1,4 +1,4 @@
-#!/usr/bin/perl
+#!@PERL@
# global exception list file
my $global_list = '../../ExceptionCodes.txt';
diff --git a/lib/compress/Makefile.extra b/lib/compress/Makefile.extra
index 7ef9930c..3598f1c9 100644
--- a/lib/compress/Makefile.extra
+++ b/lib/compress/Makefile.extra
@@ -3,5 +3,5 @@ MAKEEXCEPTION = ../../lib/common/makeexception.pl
# AUTOGEN SEEDING
autogen_CompressException.h autogen_CompressException.cpp: $(MAKEEXCEPTION) CompressException.txt
- perl $(MAKEEXCEPTION) CompressException.txt
+ $(PERL) $(MAKEEXCEPTION) CompressException.txt
diff --git a/lib/crypto/Makefile.extra b/lib/crypto/Makefile.extra
index a7e42000..f9d63a42 100644
--- a/lib/crypto/Makefile.extra
+++ b/lib/crypto/Makefile.extra
@@ -3,5 +3,5 @@ MAKEEXCEPTION = ../../lib/common/makeexception.pl
# AUTOGEN SEEDING
autogen_CipherException.cpp autogen_CipherException.h: $(MAKEEXCEPTION) CipherException.txt
- perl $(MAKEEXCEPTION) CipherException.txt
+ $(PERL) $(MAKEEXCEPTION) CipherException.txt
diff --git a/lib/raidfile/Makefile.extra b/lib/raidfile/Makefile.extra
index 8d036633..4d904e8a 100644
--- a/lib/raidfile/Makefile.extra
+++ b/lib/raidfile/Makefile.extra
@@ -3,5 +3,5 @@ MAKEEXCEPTION = ../../lib/common/makeexception.pl
# AUTOGEN SEEDING
autogen_RaidFileException.h autogen_RaidFileException.cpp: $(MAKEEXCEPTION) RaidFileException.txt
- perl $(MAKEEXCEPTION) RaidFileException.txt
+ $(PERL) $(MAKEEXCEPTION) RaidFileException.txt
diff --git a/lib/raidfile/raidfile-config b/lib/raidfile/raidfile-config
index b3f31077..f1098adc 100755
--- a/lib/raidfile/raidfile-config
+++ b/lib/raidfile/raidfile-config
@@ -1,4 +1,4 @@
-#!/usr/bin/perl
+#!@PERL@
use strict;
# should be running as root
diff --git a/lib/server/Makefile.extra b/lib/server/Makefile.extra
index 6cc0de2e..33fac0a1 100644
--- a/lib/server/Makefile.extra
+++ b/lib/server/Makefile.extra
@@ -3,9 +3,9 @@ MAKEEXCEPTION = ../../lib/common/makeexception.pl
# AUTOGEN SEEDING
autogen_ServerException.h autogen_ServerException.cpp: $(MAKEEXCEPTION) ServerException.txt
- perl $(MAKEEXCEPTION) ServerException.txt
+ $(PERL) $(MAKEEXCEPTION) ServerException.txt
# AUTOGEN SEEDING
autogen_ConnectionException.h autogen_ConnectionException.cpp: $(MAKEEXCEPTION) ConnectionException.txt
- perl $(MAKEEXCEPTION) ConnectionException.txt
+ $(PERL) $(MAKEEXCEPTION) ConnectionException.txt
diff --git a/lib/server/makeprotocol.pl b/lib/server/makeprotocol.pl
index 71355e62..3dce6118 100755
--- a/lib/server/makeprotocol.pl
+++ b/lib/server/makeprotocol.pl
@@ -1,4 +1,4 @@
-#!/usr/bin/perl
+#!@PERL@
use strict;
# Make protocol C++ classes from a protocol description file