summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosef Bacik <jbacik@fb.com>2014-09-25 16:07:10 -0400
committerDavid Sterba <dsterba@suse.cz>2014-10-01 16:34:29 +0200
commit3ae0209d94776faaa139fcebfafa22fd7840b9f4 (patch)
treeaff0995e2e6bb3614f1a40e4bf1648ede9c341b0
parentafc850dd13e672db63f6ba1faab9d4da6182f5b8 (diff)
Btrfs-progs: make BUG*() be more verbose
Currently these macros just tie to assert(), which gives us line number and such but no backtrace so no actual context. This patch adds support for spitting out a backtrace so we can see how we got to the given assert. Thanks, Signed-off-by: Josef Bacik <jbacik@fb.com> [backtrace_symbols_fd] Signed-off-by: Naohiro Aota <naota@elisp.net> [minor fixups] Signed-off-by: David Sterba <dsterba@suse.cz>
-rw-r--r--Makefile2
-rw-r--r--kerncompat.h36
2 files changed, 33 insertions, 5 deletions
diff --git a/Makefile b/Makefile
index 18eb9445..7cc77839 100644
--- a/Makefile
+++ b/Makefile
@@ -5,7 +5,7 @@ CC = gcc
LN = ln
AR = ar
AM_CFLAGS = -Wall -D_FILE_OFFSET_BITS=64 -DBTRFS_FLAT_INCLUDES -fno-strict-aliasing -fPIC
-CFLAGS = -g -O1 -fno-strict-aliasing
+CFLAGS = -g -O1 -fno-strict-aliasing -rdynamic
objects = ctree.o disk-io.o radix-tree.o extent-tree.o print-tree.o \
root-tree.o dir-item.o file-item.o inode-item.o inode-map.o \
extent-cache.o extent_io.o volumes.o utils.o repair.o \
diff --git a/kerncompat.h b/kerncompat.h
index bb03194e..19c7fa51 100644
--- a/kerncompat.h
+++ b/kerncompat.h
@@ -29,6 +29,7 @@
#include <stddef.h>
#include <linux/types.h>
#include <stdint.h>
+#include <execinfo.h>
#define ptr_to_u64(x) ((u64)(uintptr_t)x)
#define u64_to_ptr(x) ((void *)(uintptr_t)x)
@@ -54,7 +55,33 @@
#define ULONG_MAX (~0UL)
#endif
-#define BUG() assert(0)
+#define MAX_BACKTRACE 16
+static inline void print_trace(void)
+{
+ void *array[MAX_BACKTRACE];
+ size_t size;
+
+ size = backtrace(array, MAX_BACKTRACE);
+ backtrace_symbols_fd(array, size, 2);
+}
+
+static inline void assert_trace(const char *assertion, const char *filename,
+ const char *func, unsigned line, int val)
+{
+ if (val)
+ return;
+ if (assertion)
+ fprintf(stderr, "%s:%d: %s: Assertion `%s` failed.\n",
+ filename, line, func, assertion);
+ else
+ fprintf(stderr, "%s:%d: %s: Assertion failed.\n", filename,
+ line, func);
+ print_trace();
+ exit(1);
+}
+
+#define BUG() assert_trace(NULL, __FILE__, __func__, __LINE__, 0)
+
#ifdef __CHECKER__
#define __force __attribute__((force))
#define __bitwise__ __attribute__((bitwise))
@@ -237,9 +264,10 @@ static inline long IS_ERR(const void *ptr)
#define kstrdup(x, y) strdup(x)
#define kfree(x) free(x)
-#define BUG_ON(c) assert(!(c))
-#define WARN_ON(c) assert(!(c))
-#define ASSERT(c) assert(c)
+#define BUG_ON(c) assert_trace(#c, __FILE__, __func__, __LINE__, !(c))
+
+#define WARN_ON(c) BUG_ON(c)
+#define ASSERT(c) assert_trace(#c, __FILE__, __func__, __LINE__, (c))
#define container_of(ptr, type, member) ({ \
const typeof( ((type *)0)->member ) *__mptr = (ptr); \