summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Sterba <dsterba@suse.com>2017-11-14 15:24:39 +0100
committerDavid Sterba <dsterba@suse.com>2017-11-14 15:59:01 +0100
commitf79008960b9000a9b534b706519e895c1ebed96d (patch)
tree69780a0a08e71d28c0115d9aa6445894f55ef4f2
parent658cc4daa6ed6e6463cba2f30731abd9a91a7b2d (diff)
btrfs-progs: build: require libzstd support by default
The kernel 4.14 supports zstd, for version parity the btrfs-progs now require libzstd by default. This can still be disabled by ./configure --disable-zstd. Signed-off-by: David Sterba <dsterba@suse.com>
-rw-r--r--INSTALL2
-rw-r--r--configure.ac4
2 files changed, 3 insertions, 3 deletions
diff --git a/INSTALL b/INSTALL
index e7f81849..686cefb9 100644
--- a/INSTALL
+++ b/INSTALL
@@ -7,7 +7,7 @@ The Btrfs utility programs require the following libraries/tools to build:
- libblkid - block device id library
- liblzo2 - LZO data compression library
- zlib - ZLIB data compression library
-- libzstd - ZSTD data compression library version >= 1.0.0 (optional)
+- libzstd - ZSTD data compression library version >= 1.0.0
For the btrfs-convert utility:
diff --git a/configure.ac b/configure.ac
index adceafc3..290dc1d5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -183,8 +183,8 @@ PKG_CHECK_MODULES(ZLIB, [zlib])
PKG_STATIC(ZLIB_LIBS_STATIC, [zlib])
AC_ARG_ENABLE([zstd],
- AS_HELP_STRING([--enable-zstd@<:@=auto@:>@], [build with zstd support (default: auto)]),
- [], [enable_zstd=auto]
+ AS_HELP_STRING([--disable-zstd@<:@=yes@:>@], [build with zstd support (default: yes)]),
+ [], [enable_zstd=yes]
)
if test "x$enable_zstd" = xauto; then