summaryrefslogtreecommitdiff
path: root/Makefile.in
diff options
context:
space:
mode:
authorDavid Sterba <dsterba@suse.cz>2015-06-02 15:00:32 +0200
committerDavid Sterba <dsterba@suse.cz>2015-06-02 15:56:43 +0200
commit10b6b0b3a8288ed825d003788d9ff5d657f2e404 (patch)
tree963f7977ab693b7aa08159f10585e88e147a9f39 /Makefile.in
parent0933ef5325ee7db9879d7374d9055e912fcde18f (diff)
btrfs-progs: tests: add driver script for misc tests
Signed-off-by: David Sterba <dsterba@suse.cz>
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.in b/Makefile.in
index 14049b58..58aecc7c 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -169,11 +169,15 @@ test-fsck: btrfs btrfs-image btrfs-corrupt-block btrfs-debug-tree mkfs.btrfs
@echo " [TEST] fsck-tests.sh"
$(Q)bash tests/fsck-tests.sh
+test-misc: btrfs btrfs-image btrfs-corrupt-block btrfs-debug-tree mkfs.btrfs btrfstune
+ @echo " [TEST] misc-tests.sh"
+ $(Q)bash tests/misc-tests.sh
+
test-clean:
@echo "Cleaning tests"
$(Q)bash tests/clean-tests.sh
-test: test-fsck test-convert
+test: test-fsck test-convert test-misc
#
# NOTE: For static compiles, you need to have all the required libs