summaryrefslogtreecommitdiff
path: root/Makefile.in
diff options
context:
space:
mode:
authorDavid Sterba <dsterba@suse.com>2016-11-30 12:37:47 +0100
committerDavid Sterba <dsterba@suse.com>2016-11-30 12:42:28 +0100
commit917f2c36e1ab7aa363c195527ce7fd6c8c292e8b (patch)
tree990d855198c6981294d9dd51079b44e026ecddf5 /Makefile.in
parent18b1364e68d155a842fc7b054a4d1e916c69e40a (diff)
btrfs-progs: test: fix static build of library-test
The static variant of the test was broken, but not really used anyway. Use the right compilation and linking flags. Signed-off-by: David Sterba <dsterba@suse.com>
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.in b/Makefile.in
index 6a6652c5..5c4a995c 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -449,9 +449,9 @@ library-test: $(libs_shared) library-test.o
@echo " [TEST] $@"
$(Q)./$@
-library-test.static: $(libs_static) library-test.o
+library-test.static: $(libs_static) library-test.static.o
@echo " [LD] $@"
- $(Q)$(CC) $(CFLAGS) -o library-test-static library-test.o $(LDFLAGS) $(libs_static)
+ $(Q)$(CC) $(STATIC_CFLAGS) -o library-test.static library-test.static.o $(STATIC_LDFLAGS) $(libs_static) $(STATIC_LIBS)
@echo " [TEST] $@"
$(Q)./$@