summaryrefslogtreecommitdiff
path: root/Makefile.in
diff options
context:
space:
mode:
authorArnd Hannemann <arnd@arndnet.de>2015-09-05 01:06:18 +0200
committerDavid Sterba <dsterba@suse.com>2015-09-08 13:53:33 +0200
commitafff169e1a16795e6d150536ac146481f39d9e82 (patch)
treefbaed71c4f052b55c02783e8d0ee35acd6e5ffba /Makefile.in
parent59cc65a4e693fcb2ea868f97e89908fdf27bd713 (diff)
btrfs-progs: makefile: drop u option from ar invocation
In newer distros (ubuntu 15.10, fedora rawhide) the binutils ar uses the new D flag per default to build deterministic binaries. Without this patch the following warning is issued, when building btrfs-progs: [AR] libbtrfs.a /usr/bin/ar: `u' modifier ignored since `D' is the default (see `U') For libtrfs.a performance benefit of the u option can be neglected, so drop the u option and silence the warning. In the future one might want to explicitly add the D option anyway. Signed-off-by: Arnd Hannemann <arnd@arndnet.de> Signed-off-by: David Sterba <dsterba@suse.com>
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.in b/Makefile.in
index 665f83c0..514a76f2 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -199,7 +199,7 @@ $(libs_shared): $(libbtrfs_objects) $(lib_links) send.h
$(libs_static): $(libbtrfs_objects)
@echo " [AR] $@"
- $(Q)$(AR) cru libbtrfs.a $(libbtrfs_objects)
+ $(Q)$(AR) cr libbtrfs.a $(libbtrfs_objects)
$(lib_links):
@echo " [LN] $@"