summaryrefslogtreecommitdiff
path: root/Makefile.inc.in
diff options
context:
space:
mode:
authorOmar Sandoval <osandov@fb.com>2018-02-15 11:04:47 -0800
committerDavid Sterba <dsterba@suse.com>2018-02-24 01:37:16 +0100
commit502e2a3510c5db03335c0df8abc7f9804a65207b (patch)
tree09aa390489e91d46aa92ac2bd49528cb7ad8304a /Makefile.inc.in
parent510bb4ccc4258567e731b81c4722a6adc7faec8b (diff)
Add libbtrfsutil
Currently, users wishing to manage Btrfs filesystems programatically have to shell out to btrfs-progs and parse the output. This isn't ideal. The goal of libbtrfsutil is to provide a library version of as many of the operations of btrfs-progs as possible and to migrate btrfs-progs to use it. Rather than simply refactoring the existing btrfs-progs code, the code has to be written from scratch for a couple of reasons: * A lot of the btrfs-progs code was not designed with a nice library API in mind in terms of reusability, naming, and error reporting. * libbtrfsutil is licensed under the LGPL, whereas btrfs-progs is under the GPL, which makes it dubious to directly copy or move the code. Eventually, most of the low-level btrfs-progs code should either live in libbtrfsutil or the shared kernel/userspace filesystem code, and btrfs-progs will just be the CLI wrapper. This first commit just includes the build system changes, license, README, and error reporting helper. Signed-off-by: Omar Sandoval <osandov@fb.com> Reviewed-by: Liu Bo <bo.li.liu@oracle.com> Signed-off-by: David Sterba <dsterba@suse.com>
Diffstat (limited to 'Makefile.inc.in')
-rw-r--r--Makefile.inc.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.inc.in b/Makefile.inc.in
index 56271903..b53bef80 100644
--- a/Makefile.inc.in
+++ b/Makefile.inc.in
@@ -27,7 +27,7 @@ prefix ?= @prefix@
exec_prefix = @exec_prefix@
bindir = @bindir@
libdir ?= @libdir@
-incdir = @includedir@/btrfs
+incdir = @includedir@
udevdir = @UDEVDIR@
udevruledir = ${udevdir}/rules.d