summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorChris Mason <chris.mason@oracle.com>2010-03-11 09:38:52 -0500
committerChris Mason <chris.mason@oracle.com>2010-03-11 09:38:52 -0500
commit06cbf62fda156d1399022158d671353d1a3aeaec (patch)
tree4e7e8d8bd072299386301b44bba366a496b73c62 /Makefile
parent7b14bc0f4ffaf64be53b2ee531bb1774502d6a8f (diff)
Add new defrag range ioctl that can also compress files on demand.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index f2a9d41a..10002681 100644
--- a/Makefile
+++ b/Makefile
@@ -17,7 +17,7 @@ bindir = $(prefix)/bin
LIBS=-luuid
progs = btrfsctl mkfs.btrfs btrfs-debug-tree btrfs-show btrfs-vol btrfsck \
- btrfs-map-logical btrfs-list
+ btrfs-map-logical btrfs-list btrfs-defrag
# make C=1 to enable sparse
ifdef C
@@ -39,6 +39,9 @@ version:
btrfs-list: $(objects) btrfs-list.o
gcc $(CFLAGS) -o btrfs-list btrfs-list.o $(objects) $(LDFLAGS) $(LIBS)
+btrfs-defrag: $(objects) btrfs-defrag.o
+ gcc $(CFLAGS) -o btrfs-defrag btrfs-defrag.o $(objects) $(LDFLAGS) $(LIBS)
+
btrfsctl: $(objects) btrfsctl.o
gcc $(CFLAGS) -o btrfsctl btrfsctl.o $(objects) $(LDFLAGS) $(LIBS)