summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorChris Mason <chris.mason@oracle.com>2008-04-22 14:06:31 -0400
committerDavid Woodhouse <dwmw2@hera.kernel.org>2008-04-22 14:06:31 -0400
commit358564890ac230ccc8af2661268a6bcb0d6ea18f (patch)
treeaea7067c1cc525b4c443fcb52920f1a34b08a935 /Makefile
parentb569dafbf2acfb99f8c0546ad28cb61f860f30db (diff)
Add a command to show all of the btrfs filesystems on the box (btrfs-show)
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 63fddcf0..e6fbf628 100644
--- a/Makefile
+++ b/Makefile
@@ -15,7 +15,7 @@ prefix ?= /usr/local
bindir = $(prefix)/bin
LIBS=-luuid
-progs = btrfsctl btrfsck mkfs.btrfs debug-tree quick-test
+progs = btrfsctl btrfsck mkfs.btrfs debug-tree quick-test btrfs-show
# make C=1 to enable sparse
ifdef C
@@ -34,6 +34,9 @@ all: $(progs)
btrfsctl: $(objects) btrfsctl.o
gcc $(CFLAGS) -o btrfsctl btrfsctl.o $(objects) $(LDFLAGS) $(LIBS)
+btrfs-show: $(objects) btrfs-show.o
+ gcc $(CFLAGS) -o btrfs-show btrfs-show.o $(objects) $(LDFLAGS) $(LIBS)
+
btrfsck: $(objects) btrfsck.o bit-radix.o
gcc $(CFLAGS) -o btrfsck btrfsck.o $(objects) bit-radix.o $(LDFLAGS) $(LIBS)