summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorDavid Sterba <dsterba@suse.com>2017-03-15 12:21:50 +0100
committerDavid Sterba <dsterba@suse.com>2017-03-16 17:02:44 +0100
commitb5d4b3cef3504b1ca6734ca8fd56b8d6a1c304ac (patch)
tree5798f43ca0d7c6278f1c279550a986c87e603a79 /Makefile
parent4ddd6055c333932b561046ad1d41234d773246d2 (diff)
btrfs-progs: tests: fssum, switch from MD5 to SHA256
Signed-off-by: David Sterba <dsterba@suse.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 3a713d3f..9e2e6d5c 100644
--- a/Makefile
+++ b/Makefile
@@ -466,10 +466,9 @@ library-test.static: library-test.c messages.static.o $(libs_static)
@echo " [TEST CLEAN] $@"
$(Q)$(RM) -rf -- $(TMPD)
-fssum: tests/fssum.c
+fssum: tests/fssum.c tests/sha224-256.c
@echo " [LD] $@"
- # FIXME: no configure-time check for libcrypto from SSL
- $(Q)$(CC) $(CFLAGS) -o $@ $< $(LDFLAGS) -lcrypto
+ $(Q)$(CC) $(CFLAGS) -o $@ $^ $(LDFLAGS)
test-build: test-build-pre test-build-real