summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorDavid Sterba <dsterba@suse.com>2017-08-14 15:09:45 +0200
committerDavid Sterba <dsterba@suse.com>2017-08-24 19:06:12 +0200
commitf929b62ae8e99f41322c4d6f3840cec7a7f6474b (patch)
tree21133cf97e51049d89e88a4e96a98a0e298260b4 /Makefile
parent0607132c3200bcead1426e6dc685432008de95de (diff)
btrfs-progs: build: do not regenerate kernel-lib/tables.c
As reported in https://www.mail-archive.com/linux-btrfs@vger.kernel.org/msg66765.html cross-compilation does not work very well with current tables.c. We can simpy keep the pergenerated file in the repository and update if needed. Signed-off-by: David Sterba <dsterba@suse.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index b3e2b636..0cee85ff 100644
--- a/Makefile
+++ b/Makefile
@@ -325,7 +325,9 @@ mktables: kernel-lib/mktables.c
@echo " [CC] $@"
$(Q)$(CC) $(CFLAGS) $< -o $@
-kernel-lib/tables.c: mktables
+# the target can be regenerated manually using mktables, but a local copy is
+# kept so the build process is simpler
+kernel-lib/tables.c:
@echo " [TABLE] $@"
$(Q)./mktables > $@ || ($(RM) -f $@ && exit 1)
@@ -518,7 +520,6 @@ clean: $(CLEANDIRS)
$(Q)$(RM) -f -- $(progs) *.o *.o.d \
kernel-lib/*.o kernel-lib/*.o.d \
kernel-shared/*.o kernel-shared/*.o.d \
- kernel-lib/tables.c \
image/*.o image/*.o.d \
convert/*.o convert/*.o.d \
mkfs/*.o mkfs/*.o.d \