summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorJan Engelhardt <jengelh@computergmbh.de>2008-01-22 11:32:07 -0500
committerDavid Woodhouse <dwmw2@hera.kernel.org>2008-01-22 11:32:07 -0500
commitfd4bca3dfea947f7031721be0a6ebf365b313fb8 (patch)
tree2c94e9040a52adfdd0047b57c467b4702a6679e9 /Makefile
parent4408248634ecf2b4c1e246b9fd0c770984f69aae (diff)
btrfs-progs: build with -D_FORTIFY_SOURCE=2
Add -D_FORTIFY_SOURCE=2 to the makeflags. It has been very helpful in finding problems. Signed-off-by: Jan Engelhardt <jengelh@computergmbh.de> --- Makefile | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index a2303018..115be6b4 100644
--- a/Makefile
+++ b/Makefile
@@ -1,5 +1,5 @@
CC=gcc
-AM_CFLAGS = -Wall -fno-strict-aliasing -D_FILE_OFFSET_BITS=64
+AM_CFLAGS = -Wall -fno-strict-aliasing -D_FILE_OFFSET_BITS=64 -D_FORTIFY_SOURCE=2
CFLAGS = -g -Werror
objects = ctree.o disk-io.o radix-tree.o extent-tree.o print-tree.o \
root-tree.o dir-item.o hash.o file-item.o inode-item.o \