summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak <kzak@redhat.com>2014-12-10 11:56:59 +0100
committerDavid Sterba <dsterba@suse.cz>2015-01-28 18:01:00 +0100
commit2c2e6c4e12e5af15fd80eb282df28a6b2c6c8d00 (patch)
treeda64e82e7581ef4ba05f7a01e8581d5b57197b5f /configure.ac
parent8e14f8de17c445221f81cf3d2551d1278960e69e (diff)
btrfs-progs: autoconf: cleanup compilation flags usage
- define basic default CFLAGS in configure.ac, because: * autoconf default is -g -O2, but btrfs uses -g -O1 * it's better to follow autoconf; standard way to modify CFLAGS is to call: CFLAGS="foo bar" ./configure - move all flags to one place in Makefile.in - don't use AM_CFLAGS, the CFLAGS and STATIC_CFLAGS are enough - don't mix objects and flags in $LIBS, it's more readable to add $(libs) to make rules Signed-off-by: Karel Zak <kzak@redhat.com> Signed-off-by: David Sterba <dsterba@suse.cz>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 662d9ffe..f6adefbf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8,6 +8,8 @@ LIBBTRFS_MAJOR=0
LIBBTRFS_MINOR=1
LIBBTRFS_PATCHLEVEL=1
+CFLAGS="-g -O1"
+
AC_PREREQ([2.60])
AC_CONFIG_AUX_DIR([config])