summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorOmar Sandoval <osandov@fb.com>2018-02-27 12:42:38 -0800
committerDavid Sterba <dsterba@suse.com>2018-03-30 22:15:53 +0200
commitf44a0550123be92245943d832df64134c5fd6241 (patch)
tree1df8b1fe8d3c7c36d3357d43278670458333d971 /configure.ac
parent58b5610845a7a0578b7af1a1161ae4b4b3383aac (diff)
libbtrfsutil: use pkg-config detection for the right Python version
The user may have specified a different version of Python than the python3 from their $PATH (e.g., with PYTHON=/usr/bin/python3.6). Signed-off-by: Omar Sandoval <osandov@fb.com> Signed-off-by: David Sterba <dsterba@suse.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index dcc98ea7..af13a959 100644
--- a/configure.ac
+++ b/configure.ac
@@ -219,7 +219,7 @@ AC_ARG_ENABLE([python],
if test "x$enable_python" = xyes; then
AM_PATH_PYTHON([3.4])
- PKG_CHECK_MODULES(PYTHON, [python3])
+ PKG_CHECK_MODULES(PYTHON, [python-${PYTHON_VERSION}])
fi
AS_IF([test "x$enable_python" = xyes], [PYTHON_BINDINGS=1], [PYTHON_BINDINGS=0])