summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Sterba <dsterba@suse.cz>2015-02-13 14:39:43 +0100
committerDavid Sterba <dsterba@suse.cz>2015-02-13 14:39:43 +0100
commitfef4f9e50bdd9bb7a410234d8bef289009477f33 (patch)
treed4b4c93d4ce0c7710a0f2b2b96c8c67b5940d9f5 /configure.ac
parentc02b4adcb6a529a29f429db3020405f9aefc2f0d (diff)
btrfs-progs: autoconf: define package url manually if not set
The PACKAGE_URL is set from optional parameter of AC_INIT starting in autoconf 2.64. There are enterprise distros with version 2.63, we can make the build work there easily as well. Fixes build failure: mkfs.c: In function ?main?: mkfs.c:1492: error: ?PACKAGE_URL? undeclared (first use in this function) Reported-by: Eric Sandeen <sandeen@redhat.com> Signed-off-by: David Sterba <dsterba@suse.cz>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0692d5a8..2ee435d9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,6 +3,10 @@ AC_INIT([btrfs-progs],
[linux-btrfs@vger.kernel.org],,
[http://btrfs.wiki.kernel.org])
+if test "x$PACKAGE_URL" = "x"; then
+ AC_DEFINE([PACKAGE_URL], ["http://btrfs.wiki.kernel.org"], [URL])
+fi
+
dnl library version
LIBBTRFS_MAJOR=0
LIBBTRFS_MINOR=1