summaryrefslogtreecommitdiff
path: root/version.h.in
diff options
context:
space:
mode:
authorNicholas D Steeves <nsteeves@gmail.com>2016-04-23 00:41:30 +0100
committerNicholas D Steeves <nsteeves@gmail.com>2016-04-23 00:41:30 +0100
commitcec572daccafa1e912cbed363df6f84687778c6f (patch)
tree7d99ab9f73d25c1ed8eaf6393f6374edf5316b03 /version.h.in
btrfs-progs (4.4.1-1.1) unstable; urgency=medium
* Non-maintainer upload. * New upstream release. * Rename package to btrfs-progs (Closes: #780081) * Update standards version to 3.9.7 (no changes needed). * debian/control: Add "Breaks" per Gianfranco Costamagna's suggestion * Change lintian override to reflect package rename * Switch from using postinst and postrm to using triggers per Christian Seiler's recommendation. # imported from the archive
Diffstat (limited to 'version.h.in')
-rw-r--r--version.h.in14
1 files changed, 14 insertions, 0 deletions
diff --git a/version.h.in b/version.h.in
new file mode 100644
index 00000000..db5ad51f
--- /dev/null
+++ b/version.h.in
@@ -0,0 +1,14 @@
+#ifndef __LIBBTRFS_VERSION_H__
+#define __LIBBTRFS_VERSION_H__
+
+#define BTRFS_LIB_MAJOR @LIBBTRFS_MAJOR@
+#define BTRFS_LIB_MINOR @LIBBTRFS_MINOR@
+#define BTRFS_LIB_PATCHLEVEL @LIBBTRFS_PATCHLEVEL@
+
+#define BTRFS_LIB_VERSION ( BTRFS_LIB_MAJOR * 10000 + \
+ BTRFS_LIB_MINOR * 100 + \
+ BTRFS_LIB_PATCHLEVEL )
+
+#define BTRFS_BUILD_VERSION "Btrfs @PACKAGE_VERSION@"
+
+#endif