summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDidier Raboud <odyx@debian.org>2016-10-05 08:06:35 +0200
committerDidier Raboud <odyx@debian.org>2016-10-05 08:06:35 +0200
commit2b6b6a1e24dbfadc4177059eae8ad8050c5972f3 (patch)
treea09655a7a8db9be03970b2a35c39e1a53a5f96a0
parentf89b1fada0f1262be06de90dbdf16a0a1ddc26e5 (diff)
Inherit CFLAGS and LDFLAGS from the environment. Also use CPPFLAGS in the building command
Last-Update: 2014-04-13 Gbp-Pq: Name inherit_FLAGS_from_environment.patch
-rw-r--r--Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 727aa49..5fc6601 100644
--- a/Makefile
+++ b/Makefile
@@ -10,8 +10,8 @@
# Important compiler and linker options
CC=gcc
LD=gcc
-CFLAGS=-g -O2
-LDFLAGS=-g -O2
+CFLAGS+=-g -O2
+LDFLAGS+=-g -O2
# Required libraries
LDLIBS=
@@ -23,7 +23,7 @@ MOD=$(SRC:.c=.o)
# Standard production rule
.c.o:
- $(CC) $(CFLAGS) -c $<
+ $(CC) $(CPPFLAGS) $(CFLAGS) -c $<
# make all
all: c2050