summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorStephane Glondu <steph@glondu.net>2015-05-19 10:23:03 +0200
committerStephane Glondu <steph@glondu.net>2015-05-19 10:39:02 +0200
commit42052b461662c9d7c7312be667de3a66f634cad4 (patch)
tree79ad846399d9f91693a8a720782500bc7674145a /debian
parentb26089bc3dffcf61ea4d3f32c0fd560a8624a8a3 (diff)
Switch to dh
Diffstat (limited to 'debian')
-rw-r--r--debian/control3
-rwxr-xr-xdebian/rules21
2 files changed, 13 insertions, 11 deletions
diff --git a/debian/control b/debian/control
index d635de0..08a6c9f 100644
--- a/debian/control
+++ b/debian/control
@@ -9,8 +9,7 @@ Build-Depends:
debhelper (>= 9),
ocaml-nox (>= 4.01),
ocaml-findlib (>= 1.4),
- dh-ocaml (>= 0.9.5~),
- cdbs
+ dh-ocaml
Standards-Version: 3.9.4
Homepage: http://calendar.forge.ocamlcore.org/
Vcs-Git: git://anonscm.debian.org/pkg-ocaml-maint/packages/calendar.git
diff --git a/debian/rules b/debian/rules
index 5a321cd..0d78581 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,22 +1,25 @@
#!/usr/bin/make -f
-include /usr/share/cdbs/1/class/makefile.mk
-include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/rules/ocaml.mk
+include /usr/share/ocaml/ocamlvars.mk
-PKGNAME = libcalendar-ocaml-dev
DESTDIR = $(CURDIR)/debian/tmp
-DEB_MAKE_INSTALL_TARGET = install OCAML_LIB_DIR=$(DESTDIR)/$(OCAML_STDLIB_DIR)
+export OCAMLFIND_DESTDIR = $(DESTDIR)/$(OCAML_STDLIB_DIR)
+
FILES_TO_BACKUP = .depend config.status
-configure/$(PKGNAME):: debian/configure-stamp
-debian/configure-stamp:
+%:
+ dh $@ --with ocaml
+
+override_dh_auto_configure:
for i in $(FILES_TO_BACKUP); do \
cp -xa $$i $$i.debian; \
done
./configure
- touch $@
-clean::
+override_dh_auto_install:
+ mkdir -p $(OCAMLFIND_DESTDIR)
+ make install
+
+override_dh_auto_clean:
rm -rf target/
for i in $(FILES_TO_BACKUP); do \
[ ! -f $$i.debian ] || mv $$i.debian $$i; \