summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBozhidar Batsov <bozhidar@batsov.com>2017-12-28 20:41:50 +0200
committerBozhidar Batsov <bozhidar@batsov.com>2017-12-28 20:41:50 +0200
commit74f7901b416efbd032bb4f8b5c25f57fdf731115 (patch)
treea75ebd4d2cd74ed4e57a02b5bf22f70426d3f7b2
parent84de0dcd22a2df289cc14954897f8e52bdd97f5a (diff)
Release 0.16 (Riga)
Enjoy!
-rw-r--r--CHANGELOG.md2
-rw-r--r--cider.el4
-rw-r--r--doc/installation.md8
3 files changed, 8 insertions, 6 deletions
diff --git a/CHANGELOG.md b/CHANGELOG.md
index d7cf56f1..b7462d38 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -2,6 +2,8 @@
## master (unreleased)
+## 0.16.0 (2017-12-28)
+
### New Features
* [#2082](https://github.com/clojure-emacs/cider/pull/2082), [cider-nrepl#440](https://github.com/clojure-emacs/cider-nrepl/pull/440): Add specialized stacktraces for clojure.spec assertions.
diff --git a/cider.el b/cider.el
index 52be9594..680e6b54 100644
--- a/cider.el
+++ b/cider.el
@@ -11,7 +11,7 @@
;; Steve Purcell <steve@sanityinc.com>
;; Maintainer: Bozhidar Batsov <bozhidar@batsov.com>
;; URL: http://www.github.com/clojure-emacs/cider
-;; Version: 0.16.0-snapshot
+;; Version: 0.16.0
;; Package-Requires: ((emacs "24.4") (clojure-mode "5.6.0") (pkg-info "0.4") (queue "0.1.1") (spinner "1.7") (seq "2.16"))
;; Keywords: languages, clojure, cider
@@ -90,7 +90,7 @@ project inference will take place."
(require 'seq)
-(defconst cider-version "0.16.0-snapshot"
+(defconst cider-version "0.16.0"
"Fallback version used when it cannot be extracted automatically.
Normally it won't be used, unless `pkg-info' fails to extract the
version from the CIDER package or library.")
diff --git a/doc/installation.md b/doc/installation.md
index 09d99992..12d11267 100644
--- a/doc/installation.md
+++ b/doc/installation.md
@@ -151,7 +151,7 @@ Use the convenient plugin for defaults, either in your project's
A minimal `profiles.clj` for CIDER would be:
```clojure
-{:repl {:plugins [[cider/cider-nrepl "0.15.1"]]}}
+{:repl {:plugins [[cider/cider-nrepl "0.16.0"]]}}
```
**Be careful not to place this in the `:user` profile, as this way CIDER's
@@ -167,7 +167,7 @@ all of their projects using a `~/.boot/profile.boot` file like so:
(require 'boot.repl)
(swap! boot.repl/*default-dependencies*
- concat '[[cider/cider-nrepl "0.15.1"]])
+ concat '[[cider/cider-nrepl "0.16.0"]])
(swap! boot.repl/*default-middleware*
conj 'cider.nrepl/cider-middleware)
@@ -194,6 +194,6 @@ It goes without saying that your project should depend on `cider-nrepl`.
***
-`x.y.z` should match the version of CIDER you're currently using (say `0.15.1`).
+`x.y.z` should match the version of CIDER you're currently using (say `0.16.0`).
For snapshot releases of CIDER you should use the snapshot of the plugin as well
-(say `0.15.1-SNAPSHOT`).
+(say `0.16.0-SNAPSHOT`).