summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMirco Bauer <meebey@debian.org>2009-03-13 23:15:51 +0000
committerMirco Bauer <meebey@debian.org>2009-03-13 23:15:51 +0000
commitfa1d9c98177495380c92b49b55019fd807e1267f (patch)
tree1dcbadad5c817fad0aba2fe054e2e59789dab7cf
parentf3c1e58334a687ba422ae224b59a10771d51f58b (diff)
* cli-nant.make
cli_nant.pm debian/dh_auto_build_nant debian/dh_auto_clean_nant: + Initial implementation of nant integration with debhelper's "dh" tool. Just include /usr/share/cli-common/cli-nant.make in your debian/rules file and you are done!
-rw-r--r--cli-nant.make1
-rw-r--r--cli_nant.pm16
-rw-r--r--debian/changelog12
-rw-r--r--debian/cli-common-dev.install4
-rwxr-xr-xdh_auto_build_nant50
-rwxr-xr-xdh_auto_clean_nant48
6 files changed, 131 insertions, 0 deletions
diff --git a/cli-nant.make b/cli-nant.make
new file mode 100644
index 0000000..7bccfd0
--- /dev/null
+++ b/cli-nant.make
@@ -0,0 +1 @@
+export DH_OPTIONS += --with=cli-nant
diff --git a/cli_nant.pm b/cli_nant.pm
new file mode 100644
index 0000000..c2c2999
--- /dev/null
+++ b/cli_nant.pm
@@ -0,0 +1,16 @@
+#!/usr/bin/perl
+# debhelper sequence file for cli-common-dev scripts
+
+use warnings;
+use strict;
+use Debian::Debhelper::Dh_Lib;
+
+insert_after("dh_auto_build", "dh_auto_build_nant");
+insert_after("dh_auto_clean", "dh_auto_clean_nant");
+
+remove_command("dh_auto_configure");
+remove_command("dh_auto_build");
+remove_command("dh_auto_test");
+remove_command("dh_auto_clean");
+
+1;
diff --git a/debian/changelog b/debian/changelog
index c726204..515b33f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,15 @@
+cli-common (0.6.2) unstable; urgency=low
+
+ * cli-nant.make
+ cli_nant.pm
+ debian/dh_auto_build_nant
+ debian/dh_auto_clean_nant:
+ + Initial implementation of nant integration with debhelper's "dh" tool.
+ Just include /usr/share/cli-common/cli-nant.make in your debian/rules
+ file and you are done!
+
+ -- Mirco Bauer <meebey@debian.org> Fri, 13 Mar 2009 00:55:01 +0100
+
cli-common (0.6.1) unstable; urgency=low
* Upload to unstable.
diff --git a/debian/cli-common-dev.install b/debian/cli-common-dev.install
index f0795c1..2a05905 100644
--- a/debian/cli-common-dev.install
+++ b/debian/cli-common-dev.install
@@ -1,11 +1,15 @@
ildasm-monodis /usr/share/cli-common/
cli.make /usr/share/cli-common/
cli.pm /usr/share/perl5/Debian/Debhelper/Sequence/
+cli-nant.make /usr/share/cli-common/
+cli_nant.pm /usr/share/perl5/Debian/Debhelper/Sequence/
dh_makeclilibs /usr/bin/
dh_clideps /usr/bin/
dh_clifixperms /usr/bin/
dh_clistrip /usr/bin/
+dh_auto_build_nant /usr/bin/
+dh_auto_clean_nant /usr/bin/
dh_installcligac /usr/bin/
postinst-cligac /usr/share/debhelper/autoscripts/
diff --git a/dh_auto_build_nant b/dh_auto_build_nant
new file mode 100755
index 0000000..aebe781
--- /dev/null
+++ b/dh_auto_build_nant
@@ -0,0 +1,50 @@
+#!/usr/bin/perl -w
+
+=head1 NAME
+
+dh_auto_build_nant - automatically builds a package that is based on nant
+
+=cut
+
+use strict;
+use Debian::Debhelper::Dh_Lib;
+
+=head1 SYNOPSIS
+
+B<dh_auto_build> [S<I<debhelper options>>] [S<B<--> I<params>>]
+
+=head1 DESCRIPTION
+
+dh_auto_build_nant is a debhelper program that tries to automatically
+build a package that is based on ant.
+
+=head1 OPTIONS
+
+=over 4
+
+=item B<--> I<params>
+
+Pass "params" to the program that is run. These can be used to supplement
+or override any standard parameters that dh_auto_build_nant passes.
+
+=back
+
+=cut
+
+init();
+
+doit("nant", @{$dh{U_PARAMS}});
+
+=head1 SEE ALSO
+
+L<debhelper(7)>
+
+This program is a part of cli-common-dev.
+
+=head1 AUTHOR
+
+Mirco Bauer <meebey@debian.org>
+
+This program is partly based on dh_auto_build developed by Joey Hess <joeyh@debian.org>
+
+=cut
diff --git a/dh_auto_clean_nant b/dh_auto_clean_nant
new file mode 100755
index 0000000..ef365ef
--- /dev/null
+++ b/dh_auto_clean_nant
@@ -0,0 +1,48 @@
+#!/usr/bin/perl -w
+
+=head1 NAME
+
+dh_auto_clean_nant - automatically cleans up after a nant build
+
+=cut
+
+use strict;
+use Debian::Debhelper::Dh_Lib;
+
+=head1 SYNOPSIS
+
+B<dh_auto_clean_nant> [S<I<debhelper options>>]
+
+=head1 DESCRIPTION
+
+dh_auto_clean_nant is a debhelper program that tries to automatically clean up
+after a nant build.
+
+=head1 OPTIONS
+
+=over 4
+
+=item B<--> I<params>
+
+Pass "params" to the program that is run. These can be used to supplement
+or override any standard parameters that dh_auto_build_nant passes.
+
+=back
+
+=cut
+
+init();
+
+doit("nant", "clean", @{$dh{U_PARAMS}});
+
+=head1 SEE ALSO
+
+L<debhelper(7)>
+
+This program is a part of cli-common-dev.
+
+=head1 AUTHOR
+
+This program is partly based on dh_auto_clean developed by Joey Hess <joeyh@debian.org>
+
+=cut