summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--cli-policy.sgml21
-rw-r--r--debian/changelog7
-rw-r--r--debian/control10
-rwxr-xr-xdh_cligacpolicy4
-rwxr-xr-xdh_clistrip2
-rwxr-xr-xgac-package-install3
-rwxr-xr-xpolicy-install6
-rw-r--r--postinst-cligacpolicy2
-rw-r--r--postrm-cligacpolicy2
9 files changed, 36 insertions, 21 deletions
diff --git a/cli-policy.sgml b/cli-policy.sgml
index 3dc91ec..d003241 100644
--- a/cli-policy.sgml
+++ b/cli-policy.sgml
@@ -21,7 +21,7 @@
</author>
<version>
- Version 0.4.3
+ Version 0.5.0
</version>
<abstract>
@@ -60,6 +60,14 @@
<p>Here are the changes to the Debian CLI Policy document.</p>
<p>
+ Changes from 0.4.4 to 0.5.0:
+ <list>
+ <item>Removed DRAFT tag, the policy is now official.</item>
+ <item><ref id="build-deps">: Added C# 3.0 to the compiler list.</item>
+ <item><ref id="file-perms">: Added dh_clifixperms as alternative to the find command.</item>
+ </list>
+ </p>
+ <p>
Changes from 0.4.2 to 0.4.3:
<list>
<item><ref id="dh_installcligac">: Fixed order of dh_installcligac calls.</item>
@@ -257,7 +265,7 @@
</p>
<p>
- Never ever install application files (<file>.exe</file>) directly into <file>/usr/bin</file>.
+ You <em>must not</em> install application files (<file>.exe</file>) directly into <file>/usr/bin</file>.
Instead create a <qref id="wrapper-script-example">wrapper script</qref>
into <file>/usr/bin</file> to allow them to be run without the <file>.exe</file> suffix.
</p>
@@ -291,6 +299,8 @@
find debian/ -type f -name "*.dll" -or -name "*.mdb" -or -name "*.cs" -or -name "*.config" | xargs chmod -x
find debian/ -type f -name "*.exe" | xargs chmod +x
</example>
+ Alternatively you can call <file>dh_clifixperms</file> after
+ <file>dh_fixperms</file>.
</p>
</sect1>
@@ -298,8 +308,8 @@ find debian/ -type f -name "*.exe" | xargs chmod +x
<heading>Build Dependencies</heading>
<p>
- At a minimum, CLI packages <em>must</em> Build-Depends on
- <package>cli-common-dev</package> (&gt;= 0.4.0) and the
+ At a minimum, CLI packages <em>should</em> Build-Depends on
+ <package>cli-common-dev</package> (&gt;= 0.4.4) and the
appropriate CLI compiler(s).
</p>
@@ -313,6 +323,9 @@ find debian/ -type f -name "*.exe" | xargs chmod +x
C# 2.0: <package>mono-gmcs</package> (&gt;= 1.1.8) | c-sharp-2.0-compiler
</item>
<item>
+ C# 3.0: <package>mono-gmcs</package> (&gt;= 1.2.5) | c-sharp-3.0-compiler
+ </item>
+ <item>
Nemerle: <package>nemerle</package> (&gt;= 0.9)
</item>
<item>
diff --git a/debian/changelog b/debian/changelog
index b78245f..ad1b368 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,5 +1,8 @@
-cli-common (0.4.10) unstable; urgency=low
+cli-common (0.5.0) unstable; urgency=low
+ * Mirco 'meebey' Bauer:
+ + Includes CLI policy version 0.5.0.
+ + Remvoed ".NET" from package descriptions.
* Dylan R. E. Moonfire
+ dh_cligacpolicy:
- Cleaned up the code to simplify the file.
@@ -7,7 +10,7 @@ cli-common (0.4.10) unstable; urgency=low
- Removed some of the variables.
- Renamed from dh_createclipolicy
- -- Dylan R. E. Moonfire <debian@mfgames.com> Tue, 17 Jul 2007 21:18:43 -0500
+ -- Mirco Bauer <meebey@debian.org> Sun, 02 Dec 2007 16:29:03 +0100
cli-common (0.4.9) unstable; urgency=low
diff --git a/debian/control b/debian/control
index cf9b78b..9ec13be 100644
--- a/debian/control
+++ b/debian/control
@@ -10,8 +10,8 @@ Standards-Version: 3.7.2
Package: cli-common
Architecture: all
Depends: perl-modules
-Description: common files between all CLI (.NET) packages
- This package must be installed if a CLI (Common Language Infrastructure)/.NET
+Description: common files between all CLI packages
+ This package must be installed if a CLI (Common Language Infrastructure)
runtime environment is desired.
.
It covers useful integration and information for CLI implementations in
@@ -25,8 +25,8 @@ Package: cli-common-dev
Architecture: all
Replaces: cli-common (<< 0.4.0)
Depends: debhelper (>= 5.0.0), perl-modules, mono-utils | cil-disassembler, mono-mcs | strong-name-tool, libxml-dom-perl
-Description: common files for building CLI (.NET) packages
- This package must be installed if a CLI (Common Language Infrastructure)/.NET
+Description: common files for building CLI packages
+ This package must be installed if a CLI (Common Language Infrastructure)
packaging environment is desired.
.
It includes debhelper scripts for managing automatic dependency tracking
@@ -34,6 +34,6 @@ Description: common files for building CLI (.NET) packages
* dh_clideps to generate cli:Depends information for debian/control
* dh_makeclilibs to create clilibs files that are needed/used by dh_clideps
* dh_installcligac to register assemblies to be late installed into a GAC
- * dh_cligacpolicy to create the CLI policy files for installing into a GAC
+ * dh_cligacpolicy to create and install the policy files into a GAC
* dh_clifixperms to fix permissions of files in CLI package build directories
* dh_clistrip to strip CLI debug symbols from package build directories
diff --git a/dh_cligacpolicy b/dh_cligacpolicy
index a6659e9..372971a 100755
--- a/dh_cligacpolicy
+++ b/dh_cligacpolicy
@@ -235,9 +235,9 @@ foreach my $package (@{$dh{DOPACKAGES}})
if (! $dh{NOSCRIPTS})
{
autoscript($package, "postinst", "postinst-cligacpolicy",
- "s/#PACKAGE#/$assembly $version_map/");
+ "s/#ASSEMBLY# #VERSION#/$assembly $version_map/");
autoscript($package, "postrm", "postrm-cligacpolicy",
- "s/#PACKAGE#/$assembly $version_map/");
+ "s/#ASSEMBLY# #VERSION#/$assembly $version_map/");
}
}
}
diff --git a/dh_clistrip b/dh_clistrip
index c0a1421..85afe68 100755
--- a/dh_clistrip
+++ b/dh_clistrip
@@ -96,7 +96,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
L<debhelper(7)>
-This program is a part of cli-common.
+This program is part of cli-common-dev.
=head1 AUTHOR
diff --git a/gac-package-install b/gac-package-install
index f5e17af..864f4b1 100755
--- a/gac-package-install
+++ b/gac-package-install
@@ -140,7 +140,6 @@ foreach my $clr (glob("/usr/share/cli-common/runtimes.d/*"))
my $t = scalar(@install) . " assemblies";
$t = "1 assembly" if (@install == 1);
- #print "D: ", join(", ", @install), "\n";
- print STDERR "* Installing $t from $pkg into $formal\n";
+ print STDOUT "* Installing $t from $pkg into $formal\n";
system($clr, "install", $pkg, @install);
}
diff --git a/policy-install b/policy-install
index 2a69f2f..90e793d 100755
--- a/policy-install
+++ b/policy-install
@@ -24,9 +24,9 @@ do
# Copy this one as a installcligac
cp $file /usr/share/cli-common/packages.d/$POLICY.installcligac
- # Install it
- /usr/share/cli-common/gac-package-install $POLICY > /dev/null
-
+ #echo "Installing GAC policy file ($POLICY) into available GACs"
+ /usr/share/cli-common/gac-package-install $POLICY > /dev/null || exit 1
+
# We just deal with the one
exit
done
diff --git a/postinst-cligacpolicy b/postinst-cligacpolicy
index 748edea..accdd5c 100644
--- a/postinst-cligacpolicy
+++ b/postinst-cligacpolicy
@@ -1,4 +1,4 @@
if [ "$1" = "configure" ] && [ -x /usr/share/cli-common/policy-install ]
then
- /usr/share/cli-common/policy-install #PACKAGE#
+ /usr/share/cli-common/policy-install #ASSEMBLY# #VERSION#
fi
diff --git a/postrm-cligacpolicy b/postrm-cligacpolicy
index 8d9fe8c..1c434cb 100644
--- a/postrm-cligacpolicy
+++ b/postrm-cligacpolicy
@@ -1,3 +1,3 @@
if [ -x /usr/share/cli-common/policy-install ] ; then
- /usr/share/cli-common/policy-install #PACKAGE#
+ /usr/share/cli-common/policy-install #ASSEMBLY# #VERSION#
fi