summaryrefslogtreecommitdiff
path: root/MacBundler
diff options
context:
space:
mode:
authorJames Cowgill <james410@cowgill.org.uk>2014-08-29 12:01:12 +0100
committerJames Cowgill <james410@cowgill.org.uk>2014-08-29 12:01:12 +0100
commit517e089547f0b721a104ad2fabc6881d2fe2fff0 (patch)
tree65e15229c45ed375b5e381c46ed016d0cc670ae2 /MacBundler
parent9535c6126d9ed34e0fdf40cc0bdd2dc01159644d (diff)
Imported Upstream version 6.1.1+dfsg
Diffstat (limited to 'MacBundler')
-rw-r--r--MacBundler/CMakeLists.txt2
-rw-r--r--MacBundler/MacBundler.project2
-rw-r--r--MacBundler/macbundler.cpp25
-rw-r--r--MacBundler/macbundler.h25
4 files changed, 53 insertions, 1 deletions
diff --git a/MacBundler/CMakeLists.txt b/MacBundler/CMakeLists.txt
index e152c66f..e591b806 100644
--- a/MacBundler/CMakeLists.txt
+++ b/MacBundler/CMakeLists.txt
@@ -27,7 +27,9 @@ if ( USE_PCH )
endif ( USE_PCH )
# Add RPATH
+if (UNIX)
set (LINKER_OPTIONS -Wl,-rpath,"${PLUGINS_DIR}")
+endif (UNIX)
FILE(GLOB SRCS "*.cpp")
diff --git a/MacBundler/MacBundler.project b/MacBundler/MacBundler.project
index 8cb49f5e..b0f81523 100644
--- a/MacBundler/MacBundler.project
+++ b/MacBundler/MacBundler.project
@@ -195,6 +195,6 @@
</Settings>
<Dependencies Name="DebugUnicode"/>
<Dependencies Name="ReleaseUnicode"/>
- <Dependencies Name="WinReleaseUnicode"/>
<Dependencies Name="WinDebugUnicode"/>
+ <Dependencies Name="WinReleaseUnicode"/>
</CodeLite_Project>
diff --git a/MacBundler/macbundler.cpp b/MacBundler/macbundler.cpp
index 88d07cf6..810ee752 100644
--- a/MacBundler/macbundler.cpp
+++ b/MacBundler/macbundler.cpp
@@ -1,3 +1,28 @@
+//////////////////////////////////////////////////////////////////////////////
+//////////////////////////////////////////////////////////////////////////////
+//
+// copyright : (C) 2014 The CodeLite Team
+// file name : macbundler.cpp
+//
+// -------------------------------------------------------------------------
+// A
+// _____ _ _ _ _
+// / __ \ | | | | (_) |
+// | / \/ ___ __| | ___| | _| |_ ___
+// | | / _ \ / _ |/ _ \ | | | __/ _ )
+// | \__/\ (_) | (_| | __/ |___| | || __/
+// \____/\___/ \__,_|\___\_____/_|\__\___|
+//
+// F i l e
+//
+// This program is free software; you can redistribute it and/or modify
+// it under the terms of the GNU General Public License as published by
+// the Free Software Foundation; either version 2 of the License, or
+// (at your option) any later version.
+//
+//////////////////////////////////////////////////////////////////////////////
+//////////////////////////////////////////////////////////////////////////////
+
#include "macbundler.h"
#include "wx/xrc/xmlres.h"
#include "wx/textfile.h"
diff --git a/MacBundler/macbundler.h b/MacBundler/macbundler.h
index 14c55d7a..0678f2b4 100644
--- a/MacBundler/macbundler.h
+++ b/MacBundler/macbundler.h
@@ -1,3 +1,28 @@
+//////////////////////////////////////////////////////////////////////////////
+//////////////////////////////////////////////////////////////////////////////
+//
+// copyright : (C) 2014 The CodeLite Team
+// file name : macbundler.h
+//
+// -------------------------------------------------------------------------
+// A
+// _____ _ _ _ _
+// / __ \ | | | | (_) |
+// | / \/ ___ __| | ___| | _| |_ ___
+// | | / _ \ / _ |/ _ \ | | | __/ _ )
+// | \__/\ (_) | (_| | __/ |___| | || __/
+// \____/\___/ \__,_|\___\_____/_|\__\___|
+//
+// F i l e
+//
+// This program is free software; you can redistribute it and/or modify
+// it under the terms of the GNU General Public License as published by
+// the Free Software Foundation; either version 2 of the License, or
+// (at your option) any later version.
+//
+//////////////////////////////////////////////////////////////////////////////
+//////////////////////////////////////////////////////////////////////////////
+
#ifndef __MacBundler__
#define __MacBundler__