summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephane Glondu <steph@glondu.net>2023-08-07 08:18:05 +0200
committerStephane Glondu <steph@glondu.net>2023-08-07 08:18:05 +0200
commit56a086c22906a9840c1a9ac04953c62f178d9d22 (patch)
tree1e883faf2edb46d0b38d296e2d7bcdd79b91036d
parent18e2cfaa223b078da96ac525e0afe0bd017e00a9 (diff)
Update packagingdebian/1.18-3
-rw-r--r--debian/changelog7
-rw-r--r--debian/control6
-rw-r--r--debian/debian-dune1
-rwxr-xr-xdebian/rules20
4 files changed, 13 insertions, 21 deletions
diff --git a/debian/changelog b/debian/changelog
index 3234222..423abef 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+cryptokit (1.18-3) unstable; urgency=medium
+
+ * Use ocaml_dune DH buildsystem
+ * Bump Standards-Version to 4.6.2
+
+ -- Stéphane Glondu <glondu@debian.org> Mon, 07 Aug 2023 08:18:01 +0200
+
cryptokit (1.18-2) unstable; urgency=medium
* Fix build with recent dune (Closes: #1041001)
diff --git a/debian/control b/debian/control
index 732b9f5..9a3108a 100644
--- a/debian/control
+++ b/debian/control
@@ -8,13 +8,13 @@ Uploaders:
Mehdi Dogguy <mehdi@debian.org>
Build-Depends:
debhelper-compat (= 13),
- ocaml-nox (>= 4),
+ ocaml (>= 4),
ocaml-dune (>= 2),
libdune-ocaml-dev,
zlib1g-dev,
libzarith-ocaml-dev,
- dh-ocaml
-Standards-Version: 4.5.0
+ dh-ocaml (>= 1.2)
+Standards-Version: 4.6.2
Rules-Requires-Root: no
Homepage: https://github.com/xavierleroy/cryptokit
Vcs-Git: https://salsa.debian.org/ocaml-team/cryptokit.git
diff --git a/debian/debian-dune b/debian/debian-dune
new file mode 100644
index 0000000..5f601db
--- /dev/null
+++ b/debian/debian-dune
@@ -0,0 +1 @@
+cryptokit
diff --git a/debian/rules b/debian/rules
index f9f78b4..92ee2c3 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,26 +1,10 @@
#!/usr/bin/make -f
+# -*- makefile -*-
-DESTDIR=$(CURDIR)/debian/tmp
include /usr/share/ocaml/ocamlvars.mk
%:
- dh $@ --with ocaml
-
-override_dh_auto_clean:
- dune clean
- rm -f src/config/config_vars.ml
+ dh $@ --with ocaml --buildsystem ocaml_dune
override_dh_auto_configure:
./configure --enable-zlib --disable-hardwaresupport
-
-override_dh_auto_build:
- dune build -p cryptokit
-
-override_dh_auto_install:
- dune install --destdir=$(DESTDIR) --prefix=/usr --libdir=$(OCAML_STDLIB_DIR)
- rm -f debian/tmp/usr/doc/cryptokit/LICENSE
-
-override_dh_auto_test:
-ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
- dune runtest -p cryptokit
-endif